9

I have a Windows 7 laptop and I am trying to set it up to broadcast Wi-Fi so that my mobile can connect to it when in the office (no mobile signal).

I've found plenty of tutorials, and while all of the steps seem to work the connection itself is not allowing my mobile to connect to the internet.

Here are the steps that I have carried out (via cmd which was opened using the Run as administrator option) -

  1. netsh wlan show drivers -
    • Hosted network supported was set to Yes.
  2. netsh wlan set hostednetwork mode=allow ssid=MySSID key=MyKey -
    • The hosted network mode has been set to allow.
    • The SSID of the hosted network has been successfully changed.
    • The user key passphrase of the hosted network has been successfully changed.
  3. netsh wlan start hostednetwork -
    • The hosted network started.
  4. Set my LAN connection up for sharing -
    • Open Control Panel\Network and Internet\Network Connections.
    • Right click my wired connection and select Properties, then the Sharing tab.
    • Select the option Allow other network users to connect through this computers's Internet connection, then choose my new SSID as created in step 2 (Allow other network users to control or disable the shared Internet connection is not checked).

Once these steps were completed I confirmed that my wired connection had shared listed under it, and the hosted network that I had created had the same domain as the wired network listed under it.

I can connect to MySSID from my mobile and I've successuflly been assigned an IP address, however, there is no internet connection.

I have found several posts suggesting that I disable every item except IPv4 from the hosted network, but unfortunately I still can't connect to the internet via my mobile.

The wired network does use a proxy, and I have tested the connection from my mobile with the proxy settings both ignored and included.

Is there somehting that I'm missing in this process, or any troubleshooting that anyone can suggest? Thanks.

0

A clue from Deepak's answer, solved this at my system.

Refer: https://www.quora.com/What-is-the-way-to-share-internet-connection-PPPOE-over-WiFi-of-my-laptop

Perhaps the sequence to follow is:

  1. stop hostednetwork
  2. ipconfig /flushdns
  3. set hostednetwork mode=allow ssid=”name of your network” key=”Password”
  4. start hostednetwork
| improve this answer | |
0

The following procedure worked for me. (via this)

1) Disable Internet Connection Sharing from your modem connection -> properties -> Sharing Tab

2) Enable it again.

3) Disconnect from the Internet.

4) Reconnect again

5) Restart ICS service from the "services.msc" window.

6) Stop the hostednetwork

7) Start the hostednetwork

8) Internet Sharing is now enabled and everything gets resolved.

| improve this answer | |
0

Try troubleshooting via control panel>network settings. It will diagnose and fix the problem (with administrator settings) automatically. (it shows error that dhcp / dhp is disabled. Do you want to enable it?) Once you click yes it will fix the problem and you will get your internet connection back.

| improve this answer | |
  • Welcome to Super User! Please read the question again carefully. Your answer does not answer the original question. OP said "I've successfully been assigned an IP address" so his issue has nothing to do with DHCP. – DavidPostill Jan 23 '16 at 17:19
0

I had similar problems, and found it was caused by 2 reasons.

Reason 1: there are 2 network connections

If you have 2 connections, one is Local Area Connection, another one is Wireless Network Connection. Both of them are connecting to your network, you are sharing the Wireless Network Connection to your hostednetwork, your mobile connection would be broken as it might try to use the Local Area Connection which is not shared. Try to unplug the one which is not sharing.

Reason 2: Anti-virus programs

Anti-virus programs would prevent the Internet access from your mobile.

How to check if Symantec is blocking the Internet access

  • Method 1
    • Disable Symantec Endpoint Protection
    • Check if the mobile can access the Internet
  • Method 2: check Symantec log
    • Try to use the mobile to access the Internet
    • Open Symantec Endpoint Protection
    • Click View Logs
    • Click Network Threat Protection -> View Logs -> Traffic Logs
    • You may find blocked logs to see why it is blocked.

Configure Firewall

NOTE: not sure if the setting is safe, please be careful.

  • Open Symantec Endpoint Protection
  • Click Status
  • Click Network Threat Protection -> Options -> Configure Firewall Rules... The menu would invisible at your home, but visible at your office.
  • Add rule "Allow hostednetwork" Rule name: "Allow hostednetwork" Action: Allow this traffic Firewall settings > Apply this rule to the following network adapter: Microsoft Virtual Wifi Miniport Adapter (192.168.137.1)

  • Add rule "Allow all outgoing" Rule name: "Allow all outgoing" Action: Allow this traffic Ports and Protocols > Traffic direction : Outgoing

| improve this answer | |
  • Has anybody tried this approach? – Jay Kannan Sep 12 '19 at 14:30
-1

I've faced exactly the same problem and found a solution that worked for me. On the mobile WiFi connection settings for the virtual hotspot, enter the same proxy server information used by the wired network.

| improve this answer | |
-2

Well!! You've tried a lot on cmd.

My recommendation is you should try "Connectify" program.

This will create a Hotspot from your WiFi Enable Laptop.

After setting up a hotspot, you can access the Internet through all the wireless devices.

| improve this answer | |
  • 1
    Thanks, but I don't think that buying commercial software is the answer here. – David Gard Feb 2 '15 at 11:47
-2

the steps you mentioned were correct!!! i did the same by referring, https://www.quora.com/What-is-the-way-to-share-internet-connection-PPPOE-over-WiFi-of-my-laptop

its working perfect!

but i had to provide static IP for the hosted network adapter and in the mobile devices as its not getting dynamic IP[dont know why!!]

check -in network sharing centre that both the hosted adapter and the wired adapter should show 'Access Type: Internet' -also check the connectivity by pinging the devices IP from your PC

| improve this answer | |
  • This does not really answer the author's question. – Ramhound Sep 2 '15 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.