1

So I have been trying to get my Lenovo y50-70 laptop, which has both the intel integrated GPU and a GTX860M, to run Linux Mint Rebecca 17.1. I have installed the ppa repository

sudo add-apt-repository ppa:xorg-edgers/ppa

and the drivers

sudo apt-get install nvidia-343

as well as the bumlbee switch that supposedly I need as well.

sudo apt-get install bumblebee bumblebee-nvidia primus

I have tried a couple of other methods as well and always after these installs when I reboot Mint I get "Cinnamon just crashed. You are currently running in Fallback mode".

Does anyone know how to successfully install and run the nvidia drivers on a laptop that implement this graphics switch?

(Also I have followed the guide with the rebecca distro 17.1 notes that say I need to change the grub boot to add "nomodeset" but to no avail).

Any Help would be great!

2 Answers 2

5

So after a lengthy process of many different methods I finally stumbled upon one that works:

This is for a fresh install of Linux Mint 17.1 (Rebecca)

  1. update completely sudo apt-get update & sudo apt-get upgrade
  2. Add 'nomodeset' to the grub loader i.e. sudo nano /etc/default/grub should look like this:

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
    GRUB_CMDLINE_LINUX=""
    
  3. install bumblebee bumblebee-nvidia bbswitch-dkms primus through synaptic package manager because there are dependancies for these three that didn't show up on the apt-get call

  4. sudo apt-get install libcuda1-331 libvdpau1 nvidia-331 nvidia-331-uvm nvidia-libopencl1-331 nvidia-opencl-icd-331 nvidia-settings screen-resolution-extra
  5. gksudo gedit /etc/bumblebee/bumblebee.conf

Change:

# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=

to:

# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia 

Also change:

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-current
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

to:

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-331
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-331:/usr/lib32/nvidia-331
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-331/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

Finally save the file, reboot and then test vblank_mode=0 glxgears you should get a high frame rate using the dedicated graphics chip.

You can also run programs with the dedicated graphics using optirun <application>

0
0

I had this same issue - crashing and getting an error about Xclient or Xserver after installing nvidia. I had to remove nvidia to get the system working again. I figured out a fix. I recommend doing this before you even try to install the nvidia drivers:

In Mint go to Menu, then Administration, then Login Window. In Login Window Preferences select Options. At the top, the Default session is probably Run Xclient script. Change it to Cinnamon. Then reboot. Then install your nvidia and it should work (or it worked for me at least).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.