1

I'm using Samba Version-4.1.6-Ubuntu. I can connect to it fine from Mac OS 10.x and Win 8 & 8.1. As soon as installed the Win 10 technical preview i get the message The account is not authorized to log in from this station.

I have done/tried the following:

- Rebooted the client
- Rebooted the server
- Upgraded all the packages on the server
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters\enablesecuritysignature 1
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters\requiresecuritysignature 0
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\enablesecuritysignature 1
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\requiresecuritysignature 0

smb.conf

[global]
    log file = /var/log/samba/log.%m
    log level = 1
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully*$
    obey pam restrictions = yes
    socket options = TCP_NODELAY IPTOS_THROUGHPUT
    map to guest = bad user
    encrypt passwords = true
    passwd program = /usr/bin/passwd %u
    passdb backend = tdbsam
    dns proxy = no
    netbios name = Mainframe
    server string = %h server (Samba, Ubuntu)
    default = media
    unix password sync = yes
    workgroup = WORKGROUP
    os level = 20
    security = user
    lanman auth = yes
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    usershare allow guests = yes
    max log size = 1000
    pam password change = yes

 [media]
    browseable = yes
    writeable = yes
    path = /data/media
    write list = comma,separated,users
    valid users = comma,separated,users
    force create mode = 777
    force user = a-username
    user = comma,separated,users
2

"Solved" this by creating a smb user with the same user name I use in Windows 10. And if I set the same password that I use in Windows, samba share does not asks for password. Otherwise, it will ask for password, but I use other user to login into it. OR you can comment the line: map to guest = bad user and it will works fine.

  • Commenting out map to guest = bad user fixed it for me. Thanks! – Maciej Swic Feb 19 '15 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.