1

My Comcast Xfinity gateway is a Technicolor TC8305C and I have it set to “bridge mode.”

If I hardwire my computer directly into the ethernet port on the back of the gateway, I get speedtests of >120mbps, no problem.

But if I insert my Linksys WRT1900AC into the loop—all wired connections—my speed tests drop to a max of 10-12mBps. This is not only from the computer but even from the router’s own software speedtest.

I have tried several different Cat5e cables between the router & gateway, with no change in numbers; while using the same cable from the computer-to-router that was working 100mbps on computer-directly-to-gateway.

I really need to use my own router for a whole variety of reasons, but I don’t want to give up 90% of my bandwidth! Am I missing some kind of router configuration setting?

8
  • Have you tired (re)flashing the firmware on the Linksys with the latest version? – Ƭᴇcʜιᴇ007 Feb 3 '15 at 22:08
  • Yes I have 1.1.8.164461 which is also the latest listed on the Linksys site. – Brian Feb 3 '15 at 22:21
  • If you take the ISP's gateway out of bridged mode and just do chained routing, does the speed change any? – Ƭᴇcʜιᴇ007 Feb 3 '15 at 22:22
  • No speed change - still 12mbps. – Brian Feb 3 '15 at 22:26
  • Can you hard-set the ports on the Linksys and the ISP gateway to negotiate at 100Mbps (instead of Auto)? – Ƭᴇcʜιᴇ007 Feb 3 '15 at 22:28
5

Someone on the Linksys forums gave me the following solution, which worked. So I figured I’d post it here:

  1. I enabled “Media Prioritization.”
  2. On media prioritization page I clicked “settings” and set the “Downstream Bandwidth” to 120mbps exactly. I left all devices at “normal priority.”

And bam, everything started going 120mbps instead of 12mbps. Yay!

My only comment is: What a weird place to hide such a thing, and how bizarre to for a user to need to configure it manually to get the higher speed. Linksys probably ought to fix that.

4
  • Was that supposed to say Mbps instead of kbps? – Spiff Feb 4 '15 at 0:44
  • Yes! Sorry - the Linksys menu for some reason makes you do it in kbps which caused my brain misfire. I have corrected the answer post. – Brian Feb 4 '15 at 0:50
  • Media prioritisation is to throttle YouTube etc so other people can still have some bandwidth left to get on with what they need to do, too ;) If you're the only person using it, eat it all & don't worry. – Tetsujin Feb 4 '15 at 9:58
  • 1
    "Media Prioritization" should never have been disabled. Disabling it prohibits operation at 802.11n and higher speeds. – David Schwartz Jul 11 '17 at 20:36
-1

"Someone on the Linksys forums gave me the following solution, which worked. So I figured I’d post it here: I enabled “Media Prioritization.” On media prioritization page I clicked “settings” and set the “Downstream Bandwidth” to 120mbps exactly. I left all devices at “normal priority.” And bam, everything started going 120mbps instead of 12mbps. Yay! My only comment is: What a weird place to hide such a thing, and how bizarre to for a user to need to configure it manually to get the higher speed. Linksys probably ought to fix that."

I 100% agree with this. I've had my Linksys EA6500 for a while now, with a 25Mbps download, and 2Mbps upload speeds with my IP. 90% of the time I would hit those speeds. Completely acceptable to me. I turned on the Media Prioritization, and setup my devices. That's all I did. Did no other settings within Media Prioritization.

I had recently upgraded my service to 100Mbps DL, and 10Mbps UL. I was getting the UL speed of 10Mbps, but was still capping at 25Mbps DL. I also did the "modem directly to computer", this told me that my new speeds were working. So it came down to the issue with the router. Like many who are pretty technical and know their way around computers and networking well enough, I rebooted, and when that didn't work, I reset the router. And re-inputted all the settings I had before. No go.

The above tip was the only one of it's kind I came across in my research. It would seem this solution doesn't seem to be a typical one. But none the less, I tried everything else, so why not give this a go. So I went into Media Prioritization setting. Went to Settings. And then I noticed that the Downstream Bandwidth was set to 25860Kbps. Which I never entered. Never even went to this part of the settings. So I changed it to 100000Kbps. Bam! Did a speed test, and was hitting 98.9 DL and 10 UL. I ended up just turning this feature off.

After I got everything working as it should, I looked into the Media Prioritization. Turns out, unless you have multiple devices and multiple people using the router, you don't need to even turn it on. If anyone is curious, all it does is when the bandwidth starts to hit it's peek, Media Prioritization throttles lower priority devices, so that the higher priority device(s) don't get a slow down. Again, you'd have to inundate the router with usage for this to happen. But if you are going to use this feature, just make sure to set the Downstream Bandwidth setting to your maximum DL bandwidth. Remember, it's in Kbps, so you'll want to convert your Mbps to Kbps. eg. If you're running 100Mbps, that's 100000Kbps.

Thank for posting this tip Brian. And yes, I agree, it is a weird place to hide such a thing, and how bizarre it is for a user to need to configure this manually to get the correct DL speed.

1
  • "Turns out, unless you have multiple devices and multiple people using the router, you don't need to even turn it on." Nonsense. You must turn it on because it's a required component of 802.11n and 802.11ac. With it off, operating at 802.11ac speeds is impossible. – David Schwartz Jul 11 '17 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.