86

Being the good citizen I am, I left-click on the "Safely Remove Hardware" icon in my taskbar, and select my USB drive to dismount.

Then I get the message:

Windows can't stop your Generic volume device because it is in use. Close any programs or windows that might be using the device, and then try again later.

Of course, being the Operating System, it knows exactly what applications are using my device. So why won't it tell me?

Or is there a way that I can find out?

  • 1
    I have had numerous occasions with Vista where I could never figure it out and it wouldn't "release" the USB until I had re-boot/shutdown. Upgraded to Win7 and have not had that problem since, so I figured, at least on my PC, it was a system driver issue. – BBlake Dec 24 '09 at 19:02
52

You can use Sysinternals Process Explorer to find the handle for any files that are open. Just select the Find menu and select Find Handle or DLL. In the dialog that opens enter the drive letter into the search box. The search results should show all of the files that are open from the drive and which process has them open.

  • 3
    After Killing the offending process, Windows would still not free the USB drive. Go figure.... – Grantly Dec 24 '15 at 13:18
  • 2
    I only explored the drive with Explorer. Then from a cmd.exe shell, I ran a backup script on that drive, which finished. Closed the cmd.exe window. Killed and restarted Explorer.exe with Taskmgr. Still, the drive is in use and won't eject. – Kaz Jul 6 '16 at 5:28
  • 3
    Process Explorer finds nothing for M:. – Kaz Jul 6 '16 at 5:47
  • 1
    If Process explorer shows nothing, you may use Nirsoft's OpenedFilesView software. You won't see which program is using the drive (or Process Explorer would have found it too) but you will still see the handles, the used files and have a possibility to close them (if you feel like risking it) – LeFauve Jul 28 '16 at 23:37
  • 4
    Windows Explorer itself can sometimes lock drives. You can relaunch Windows Explorer in the Task Manager in Windows 10 (scroll all the way down to find it). In older versions of Windows, you will have to End explorer.exe , and explicitly run explorer.exe from the File menu. – Christopher Hostage Mar 1 '17 at 17:05
99

Simpler Method: Windows (10 at least, AFAIK) creates an entry in the event log when you try to eject a removable drive and you cannot because a process has a lock on it. The two Event IDs 225 will show the process ID and the name of the process responsible for the lock.

Step by step:

1) Start the event viewer

2) Open up "Windows Logs" then "System"

3) Right click on "System" and choose "Filter Current Log"

4) In the dialog that comes up, enter "225" (without quotes) where it says "All Event IDs"

5) You will then see all events related to unable to eject because a process locked the drive.

6) Look at the timestamps on all these entries and find out which ones relate to the actual time when you tried to eject the drive.

7) Take appropriate action. Ending a task gracefully (closing the program that has the lock) is OK most of the time. Stopping the Windows Search service is also ok. Stopping an antivirus scan should be ok (if you don't suspect you have any viruses at the time). Going into the task manager and killing the process might not be ok. How to deal with this is beyond the scope of this question.

8) (Save the view...) in Actions panel (in the right frame) you could "Save Filter to Custom View..." so you'll find it in "Custom Views" (in the left frame above the "Windows Logs")

Process ID: Event Viewer Entry

Process Name: Event Viewer Entry

8) If you don't have another entry with a process name, the System process (process id 4) is holding your drive. To get around this one you will have to go to disk management and put the drive you want to eject offline. If the file is on your boot drive, you can't put it offline. In this case, see the note below:

UPDATE 2018: I've seen applications such as WhatsApp Desktop keeping handles on Chrome Canary via the System Process. Since you cannot eject the boot disk (beacuse it is in use), the solution was to use another nifty Sysinternals utility, called Handle. After you close the program which has the locked file, launch handle and run (as an example) handle64 "Chrome SxS\Application\chrome.exe" to see if the handles are still present on the file that has the PID 4 lock. Via trial and error, close each program running, until there are no more handles on the locked file.

Best method (paid)

Download and run SafelyRemove. It helps you eject the drive and if it can't do it, it displays which processes have a lock on it:

enter image description here

  • Can you please tell about number 225. How you got it ? – Ajeeb.K.P Jul 29 '16 at 4:34
  • 2
    The application System with process id 4 stopped the removal or ejection for the device ... Well... I'll try disabling Distributed Link Tracking Client and see if that helps. – Piotr Kowalski Mar 19 '17 at 8:33
  • 13
    Windows 10 Task Manager can prevent removal as well! Who new. – Alex Che Oct 12 '17 at 15:47
  • 2
    Also works well for win7. Probably works fine on win8 too. Thanks for this method. The problem can be infuriating. – Syndacate Feb 17 '18 at 11:12
  • 1
    Useful tip. Thanks for that. I have saved a custom view "Locked Devices" for future quick access to this filtered view. – Steve Crane May 18 '18 at 6:54
5

For me (Windows 7).

  1. Hit Windows key
  2. In "search programs and files: type: diskmgmt.msc
  3. In search list find entry and right click - select run as administrator
  4. Enter admin credentials to run "Disk Management" (if required)
  5. Find offending usb drive that won't eject in disk list
  6. Left hand panel, right click select "Eject"
  7. Handles "should" close - you can always double check in sys internals process explorer

Note: "Safely remove hardware and eject media" taskbar icon no longer shows usb drive - just three dots

  1. Physically remove drive
  • 3
    No left hand panel or Eject command in Windows 7 Disk Management. (Version 1.00, according to Help/About). I can Shrink it, Delete it, Mark it Active, Format, ... no Eject. – Kaz Jul 6 '16 at 5:32
  • 1
    Couldn't find Eject either, but the Offline option did the job. And don't forget to set it online again when reconnecting your storage device. – Adriano P Sep 29 '16 at 2:25
  • 2
    Recently I've used 'Offline' to stop my external USB-SSD disk which most probably was somehow used by system (Win 10), after that "safe remove" did work. Some time later I re-plugging that disk and have got disk with "RAW" partition. By executing of chkdsk /f f: file system was somehow re-enginerried, but everything landed in 'found.000'. So ... that method does not look to be really safe. Luckily i did not have anything really important on that disk ... – Xtra Coder Nov 10 '16 at 10:02
5

You can also use command line to query the Windows log, with wevtutil.exe (since Windows 7) with the knowledge that the Windows Kernel-PnP uses Event ID 225 to log system (always having process id 4) refusal to remove or eject the device USB\VID_####&PID_############ (where the #'s denote hexadecimal numbers).

wevtutil qe System /q:"*[System[(EventID=225)]]" /c:5 /f:text /rd:true
  • qe System : query events from System log
  • /q : query with XPath
  • EventID=225 means the system refused an ejection request
  • /c:5 : number of entries to retrieve (5 here)
  • /f:text : format (default is xml)
  • /rd:true : reverse order (newest first)

I use it in a batch script.

5

Here's a quick PowerShell command to query the event log and show which application is blocking drive ejection (works for me with Windows 10, probably works with 7/8 too)

Get-EventLog -LogName System -after (Get-Date).AddHours(-1) | Where-Object {$_.EventID -eq 225} | Sort-Object TimeGenerated | Format-Table -Wrap

The output will list all instances in the past hour where the system couldn't eject a disk drive. The Message column shows the process that blocked ejection. In my example below, task manager was actually the culprit and I was able to eject after closing task manager.

PS C:\Users\Jonathan> Get-EventLog -LogName System -after (Get-Date).AddHours(-1) | \Where-Object {$_.EventID -eq 225} | Sort-Object TimeGenerated | Format-Table -Wrap

   Index Time          EntryType   Source                 InstanceID Message
   ----- ----          ---------   ------                 ---------- -------
   14692 Sep 07 10:50  Warning     Microsoft-Windows-Ke          225 The application \Device\HarddiskVolume4\Windows\System32\Taskmgr.exe with process id 11972 stopped
                                   rnel-PnP                          the removal or ejection for the device USB\VID_0781&PID_5575\200445301013C111B1A0.
   14693 Sep 07 10:50  Warning     Microsoft-Windows-Ke          225 The application \Device\HarddiskVolume4\Windows\System32\Taskmgr.exe with process id 11972 stopped
                                   rnel-PnP                          the removal or ejection for the device USB\VID_0781&PID_5575\200445301013C111B1A0.
1

You can start resmon.exe (through WIN+R), go to disk > Disk Activity > Sort by File Now you can see all files being accessed by the system and which processes are accessing them, ordered by the file path (which btw starts with a drive letter). May not work with all cases, but it's a simple approach.

Restarting the computer seems "free up" device usage. Also for faster removal, you can disable windows caching on Hardware section of your device, sometimes windows will take longer than expected to flush the cache to external disk and will display that message saying that the device is in use (because it will be, by Windows itself)

  • Similar to this: In resmon.exe, in the CPU tab. Scroll down to the Associated Handles box. There is a Search Handles search box there, where you could enter the locked drive's letter. – Andrew Feb 11 '18 at 12:10
0

If you open "My Computer" and your drive is not listed under the "Removable Storage" headers, then Windows is viewing it as a fixed system resource for some reason. You will have to unmount any partitions on the drive.

If this is the case, open "Computer Management", then go to "Disk Management". For each partition on the device, right-click the partition, select "Change Drive Letters and Paths", and remove any drive letters assigned to that partition. Once you do so, you should find that the "safely eject" feature works as you had hoped.

0

Had USB that windows reported as being in use...same as everyone else here.

In Windows 10 Ctrl+Alt+Del gets to Task Manager.

Find by scrolling - Windows Explorer. and highlight.

Bottom right is a nice friendly button called "Restart Process"

Double triple check that "Windows Explorer" is the only thing highlighted.

Mouse left-click the friendly button "Restart Process".

I only had a single Explorer, others sometimes have two. Just note which one comes back on. Try and close/eject the USB. Mine worked fine, close the USB.

If yours does not eject/close, then probably it was the other Explorer. Try again and Restat that one. Good Luck.

  • 3
    Welcome to superuser: Please read the question again carefully. Your answer does not answer the original question."Can Windows tell me what is using my USB drive?"Please take a couple of minutes and read:- superuser.com/help .Answering: superuser.com/help/how-to-answer, again welcome to superuser.Thankyou – mic84 Mar 26 '18 at 8:31

protected by Ramhound Jan 28 at 0:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.