31

I run Ubuntu Hardy and Thunderbird version 2.0.0.23 (not tagging for linux/ubuntu since I think is a Thunderbird thing, but you can re-tag if appropriate).

I am really tired of the email notifications, which appear in the right bottom corner of the desktop, often (but not always) covering the desktop switch panel, which I often need to click right when the notification appears (and instead I click the notification by mistake and I become very angry!)

Is there a way to disable the notifications altogether? I don't care about them, in my workflow I just switch to Thunderbird every once in a while when I have a minute or two to read/reply the emails (of course I've searched and RTFM, without any success)

1
  • It would be cool if we also had a way to mute notifications for a certain period of time so we can focus on one task without forgetting to re-enable notifications once allotted time is up.
    – mbx
    Commented yesterday

6 Answers 6

48

Edit -> Preferences -> General -> "When new messages arrive:"

Unchecking the "Show an alert"-Box should do the trick.

3
  • 1
    The other answers are entirely wrong. I'm using Thunderbird 45.7.0 on Ubuntu 16.04 as well as Thunderbird 45.5.1 on MacOS X 10.9.5. Both have the setting mentioned as under the Preferences - MacOS lists Preferences under the Thunderbird menu item, and Ubuntu lists Preferences under Edit. There is no Tools>Options menu item in either version.
    – Mei
    Commented Feb 19, 2017 at 18:48
  • @Mei Tools->Options is where it's found on Windows Commented Jul 12, 2017 at 17:08
  • 1
    on macOS these days, the setting is in the macOS System Preferences panel under Notifications for Thunderbird Commented Dec 13, 2017 at 6:26
11

This has changed in TB 3 and is now a bit trickier to turn off. You now need to set mail.biff.show_alert to false in the Config Editor as described at http://www.upfrontsystems.co.za/Members/izak/sysadman/that-annoying-thunderbird-notification-window. For Windows folks do "Tools/Options" rather than "Edit/Preferences" for the first step.

To turn off the notification sound, change mail.biff.play_sound to false. You can also get rid of the system tray icon by changing mail.biff.show_tray_icon to false.

8

Go to Tools->Options, then on the general tab, there should be a section at the bottom titled "When a new message arrives". Uncheck the box next to "Show an Alert".

See if that does it for you.

1
  • Great, that makes it! Besides that Tools->Options is different under Linux (I wonder why they made this awful choice): kb.mozillazine.org/…
    – Davide
    Commented Dec 24, 2009 at 17:17
1

The above answer is no longer correct. As of Thunderbird 24.60, and probably earlier, the control is found here:

Tools -> Options -> General tab -> "When new messages arrive:"

Uncheck "Show an alert" box or use the Customize... button to alter the behavior of the notification if you wish.

1

Apart from new mail notifications (which are handled inside Thuderbird preferences), it seems that recent versions delegate the general notification handling to the operating system. In Ubuntu it can be found in Settings -> Notifications, where you can disable all Thunderbird notifications.

0

As of 2023, there is a gear icon at the bottom left of the window to go to "Settings". Scroll down to see Incoming Mails section. Then uncheck "Show an alert".

Or you can also hit Alt key in keyboard to show the options at the top.

Edit -> Settings -> Incoming Mails section -> Show an alert

I hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .