7

I'm using Cisco's AnyConnect to connect to a VPN using my Windows 8.1 PC. When using the Genymotion emulator, I would like it to use the VPN too. However, although having Internet access from the device, I can't connect to IPs in the VPN.
Since Genymotion uses VirtualBox, I have tried disabling the first adapter (the host-only adapter) from VirtualBox's configuration, and left the second adapter enabled (a NAT adapter). However, it wouldn't work (I took that idea from this answer).

Do you have any ideas on how could I share this VPN access to my device?

Best regards.

3
  • I am having the same problems, did you figure something out by now? Apr 12, 2017 at 11:58
  • Sorry, it's been a long time and I never had the chance to make it work (in fact, I haven't worked in Android for more than a year). Anyway, I seem to remember you could use Android Studio's emulator, instead of Genymotion, and you would have access to the VPN doing so. Hope this works for you
    – jmm
    Apr 12, 2017 at 15:35
  • 1
    Unfortunately I cannot use the official emulator, as it runs too slow. But thanks for your answer anyways. Apr 17, 2017 at 13:05

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.