I formatted my seagate external hard disk with NTFS using Ubuntu Disk Utility. After that it is bricked, and now I cannot see it as a hard disk in mac /ubuntu /windows, the device can be detected by computer.

Disk Details:
- Brand: seagate expansion portable drive
- Model: SRD00F1
- Serial: NA42Q8HM - Size: 1TB


  • when I set internal hard drive as first boot, the usb external drive, when plugged in, will make the computer failed to boot from internal hard drive.
  • diskpart and disk management can only work when they are open first and then plug in the usb hard drive, otherwise they will stuck. (see pics below)
  • sometimes when I plug in, the disk change to readonly and I follow this post, I didn't work for me.

I tried many times and also failed many times. What should I do? Is there anyway to reset hard drive?

Related Images (sorry I don't have rights to post images)

  • [BIOS recognize usb hard disk]
  • [Disk management can see hard disk but stuck]
  • [Disk change to readonly]
  • [Diskpart can see the disk]
  • [Device Manager detect usb hard disk]
  • [diskpart list volume not work]
  • [change readonly fail]

1 Answer 1


You can write zeros to the drive. This will erase all the data that is on the HDD and will reset it to factory defaults. Look for a software with a DOS version to avoid using Windows.

  • DOS can not recognize my external usb hard drive, any tools suggested to do zero fill in my usb external hard drive. Tks. Feb 6, 2015 at 3:04
  • You can have a look at Hiren's BootCD it has some useful HDD tools. Feb 6, 2015 at 15:24
  • My favorite is Western Digitals "Data Lifeguard" tools, I use it in windows for zero fill.
    – Moab
    Feb 8, 2015 at 1:06
  • @Techpumpkin_WD I have tried Hiren's BootCD. The Dos tool inside can not recognize hdd. Feb 8, 2015 at 3:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.