2

Currently facing an incomprehensible issue with Excel...

We have developed a work order electronic package that is used by about one hundred users every day. It is essentially the exact same workbook that is copied and transferred to users (for them to fill). The file is full of macros that do a variety of things...

We received new computers recently (Windows 8, 64 bit, Office 2013) and everything was working fine everywhere, at first.

Suddenly, about two weeks ago, we started getting issues that defy logic on some computers only.

On certain computers only, the workbooks simply do not work. We get unexpected runtime errors "32809" for no reason when running macros or other runtime errors for no reason... Some basic code just fails to function on certain computers only. In other words I could take the exact same file and run it on two identical computers and the same macro would throw an error on one and work perfectly on the other. I can also take a perfectly working file on one computer send it to a user, if that user simply hits "CTRL + S" then sends the file back to me, the file's macro wouldn't work anymore. This does not make sense, at all.

In the "corrupt" file, I even tried writing some new code for testing... The most basic code like Sheets("Job Time Sheet").Select won't even work. Two sheets can't be access programmatically, for some reason (again, on certain computers only).

The origin of the error seems to be two specific sheets (even though again, the workbook works fine on several computers). If I create copies, then delete them, the file starts working again. But because those two sheets can't be accessed with VBA, the repair process can't be automated and needs to be done manually, which is not acceptable.

The whole thing does not make sense. I thought that Windows/Office Updates were to blame for this and made sure that the computers we were using for testing all had the most recent updates. Didn't change a thing.

On some of the computers that were corrupting the files, we also tried uninstalling/re-installing office, with no success.

Anybody has an idea of what might be the problem????? Again, the fact that the same identical files works on 70% of the computers only defies logic. We all have the exact same computers, settings etc.

Note we did not have this problem when we were using our older computers and Windows 7/Office 2013. This all started with the new machines.

migrated from stackoverflow.com Feb 6 '15 at 4:05

This question came from our site for professional and enthusiast programmers.

  • 1
    Are you having problems with .xls files or .xlsm files ?? – Gary's Student Jan 30 '15 at 17:02
  • Considering it doesn't seem to be the programming that is the problem, this would be off-topic at SO. However, a couple of Close Votes have suggested you could try SuperUser SE. – Chrismas007 Jan 30 '15 at 17:10
  • Using xlsb or xlsm files. – user4512328 Jan 30 '15 at 17:26
2

Security Update (Dec 14) from MS is definitely the issue.

Once someone with the update saves a file, no one else can open it without issue- until they are updated- which is why it appears hit or miss... (Issue kills Active X controls.)

Office 2007

get current on all MS updates and restart

update to SP3 if necessary (not enough points to post link)

install Security update Security Update

run FixIt 51029 patch to remove exd files FixIt 51029

Office 2010/2013

get current on all MS updates and restart

run FixIt 51029 patch to remove exd files (same as above)

And yes, on all the computers...

  • Tried this... seems to work (on at least one machine). Will try on several others this week and will report back. Thank you very much!!!! – user4512328 Feb 2 '15 at 15:23
0

The december 2014 Office 'update' could be the culprit.

0

Or a lot of users choose (for now) to uninstall the Security Update (from Windows Update > Installed Updates)... But I don't think ultimately that will be the best solution as more people get "updated". Uninstall:

Office 2013 KB2726958

Office 2010 KB2553154

Office 2007 KB2596927

0

Yes I'm seeing the same issue.

We have mixed Office 2013 pre December 2014 SP, post December 2014 service pack and Office 2010.

I can save a file WITH the SP, open it under 2010 and get the error. Then save under 2010, reopen and the error goes away. Open again under 2013, save, and the error reappears. The SP seems to have broken backwards compatibility when there are activex controls on the sheet (labels and combos in my case)

Applying latest 2013 Service pack to 2013 and 2010 and removing the exd files has solved the issue in all cases so far tried.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy