1

I've been trying to set-up a host-only network between my Virtual machine Linux (Guest) and Windows 8.1 (Host) to share Internet connection of Linux VM with Windows 8.1 host. the Linux distribution i'm working with is Kali-Linux. internet connection is in VM and i want to bring it to host computer and from there share it between other computers using ICS.

i followed the instructions in here and here and found some docs but they were for older versions of Vmware workstation.

First, i tried to disable any ICS that was already running in my host Windows and then in VMware workstation settings, network adapters settings, set the network to host-only and i know that it will enable host-only network on VMnet 1 (Virtual network adapter). so i successfully connected to internet in my Linux VM but there was no internet connection coming to my Windows host through VMnet 1.

Second, i tried to set the custom options in VM settings and manually set the adapter to be VMnet 1 but still no luck.

i think there are some interference with IP addresses of my Windows and VMnet 1.

Windows (Host) IP address is 192.168.1.5 and the VMnet 1's IP address is 192.168.209.1 and it's DHCP server is 192.168.68.254.

i tried to change them using Virtual network editor of VMware worksation to set the IP address of the host-only VMnet 1 to 192.168.1.10 and it's subnet ip to 192.168.1.0 but when i go to details of VMnet 1 in Windows, it still has the old configuration.

do i need to configure my Linux VM too or am i doing things wrong? thanks in advance.

1

Your Guest OS will not get connected once your host got connected, Unless you have configured your VM's Network settings. Moreover No need to power off other virtual machines in order to gain access for your Kali. I have VMWare 11 installed on my windows 8.1 64 bit platform and I work with multiple OS es at the same time all connected to the internet and working properly.

VMWare has the following network settings. . .

1) Bridged,

2) NAT,

3) Host Only,

4) Custom

NAT will be the default selection. I was running XP SP3 and Kali at the same time and couldn't establish a connection. So what I did is, I just changed the setting from NAT to Bridged. But then XP got connected and said limited connection(You can't use your net connection when limited).

I tried all other option which were ineffective and the came back to bridged. In bridged connection select the Replicate physical network connection state. This worked perfect for my Win XP.

But still Kali was keeping on reconnecting for the same setting. For Kali I chose Custom: Specific Virtual Network. In custom I chose VMnet0(bridged) option. Then I went to Edit --->Virtual Network Editor.

When it opened, in the bridged option I chose my network adapter (mine is Realtek PCIe) (you choose your network adapter). Voila now I have no problem at all. now I have a stable connection. I am running Windows XP SP3, 7, 8, Server and Kali without any problem in my network connection.

1
  • I think you misunderstood my question. I'm not going to share Host's Internet connection with guest VMs, i'm trying to do the opposite and it's not a simple operation. for your scenario I suggest you to disable DHCP on VMnnet8 (NAT) and set it for all of your VMs and give them static IPs, so they will all reside on the same subnet as your host. – user326006 Jul 20 '15 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy