3

I'm trying to FTP into my website. I've made sure my IP address is not blocked and I'm using correct ports and credentails, yet I'm still getting this error log:

Status: Resolving address of ftp.bakealot.com
Status: Connecting to 77.72.2.194:21...
Status: Connection established, waiting for welcome message...
Status: Initializing TLS...
Error:  Received TLS alert from the server: Handshake failed (40)
Error:  Could not connect to server
Status: Waiting to retry...
Status: Resolving address of ftp.bakealot.com
Status: Connecting to 77.72.2.194:21...
Status: Connection established, waiting for welcome message...
Response:   220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:   220-You are user number 1 of 100 allowed.
Response:   220-Local time is now 16:22. Server port: 21.
Response:   220-This is a private system - No anonymous login
Response:   220-IPv6 connections are also welcome on this server.
Response:   220 You will be disconnected after 15 minutes of inactivity.
Command:    AUTH TLS
Response:   234 AUTH TLS OK.
Status: Initializing TLS...
Error:  Received TLS alert from the server: Handshake failed (40)
Error:  Could not connect to server

Where can I start to troubleshoot?

  • try to use openssl as client and make connection in verbose mode – Romeo Ninov Feb 7 '15 at 16:32
  • This site only supports the ciphers RC4-MD5 and RC4-SHA which are considered insecure. It might be that your ftp client (which one do you use?) has disabled support for RC4 by default. Apart from that the name in the certificate does not match the name you connect to. – Steffen Ullrich Feb 7 '15 at 17:01
  • @RomeoNinov apologies, I don't know how to use the command line application, openssl. – adampski Feb 7 '15 at 17:33
  • @SteffenUllrich I tried using CuteFTP Pro and FileZilla. – adampski Feb 7 '15 at 17:33
  • 1
    FileZilla works for me without problems with this site, that is TLS handshake succeeds and I could login if I had the credentials. If you are on windows make sure that RC4 is not disabled on your system, since the server can do only RC4. Maybe you have applied a fix to disable RC4, like described at support.microsoft.com/kb/2868725. – Steffen Ullrich Feb 7 '15 at 18:04
6

I had this issue in ProFTP, and got the same error message in FileZilla. For the same reason as stated, FileZilla have disabled RC4 on TLS connections. You can probably still connect without a certificate check (under Site Manager - Protocol):

enter image description here

Alternatively, and what worked for me, was to give the FTP Server the path to the SSL certificates on your server. It's specific to PureFTP though, so I can't tell you which file to patch - sorry.

This may help though: http://download.pureftpd.org/pub/pure-ftpd/doc/README.TLS

Not the answer you're looking for? Browse other questions tagged or ask your own question.