3

Pretty new to Mac, but I’m trying to share folders over the network from my laptop (Mavericks) with my wife’s (Yosemite). From my machine, the /users/brian/Public folder is sharing successfully, but other folders are not.

If I add new folders into the /users/brian/Public folder, they show up instantly on her machine, but when I attempt to share a folder from another part of my system, i.e. /Users/brian/gdrive/picasa_database (it never shows up for her).

I’ve tried sharing the folder by “right clicking on it > get info > clicking shared checkbox,” and also by going through “system preferences > sharing > file sharing > add folder.”

Neither method has worked. I have also checked permissions and both folders offer access to ”everyone.”

  • are you using the afp protocol or the smb? – bret7600 Feb 12 '15 at 15:22
  • Thanks Bret. I'm not sure. I set it up by selecting "go > connect to server" from the finder top menu. How would I find that out? – Brian FitzGerald Feb 12 '15 at 19:01
  • On the host computer in the sharing preferances, it should give you the link to the IP address of the server. – bret7600 Feb 14 '15 at 15:06
  • 1
    It may just be a sharing permissions problem. To fix this, right click on the folders you are sharing, then change the permissions from read only to read and write. 'Happy Valentines Day' – bret7600 Feb 14 '15 at 15:08
  • 4
    I'm having this problem too. When I click the "+" to add a new folder, I chose a new folder to add, but then nothing happens! Very frustrating. – Ryan Nov 17 '15 at 21:58
1

In my case, my hard drive wasn't been shown in Finder, and therefore any folder on that drive would not show up in the shared folders list (even though it was, in fact, shared.) To fix this, go to Finder | Preferences and make sure you are showing the appropriate category of things

  • Can confirm that this worked for me. – Rob Smallshire May 3 '16 at 11:22
0

I too was clicking on the + and - to change the "Shared Folders", and nothing appeared to happen. I already had Finder -> Preferences "Show these items on the desktop" Hard disks checked, so I checked "Connected servers". Then all the changes I had made appeared in the "Shared Folders box. Further changes worked OK.

I then unchecked "Hard disks" and "Connected servers" and + and - in Shared Folders still continues to work properly.

It seems as though something in Mac OS has got stuck, and changing Finder Preferences unsticks it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.