1

I'm trying to install an unsigned driver (Libusb for an AVR MKII programmer), but Windows 8.1 blocks this. I've found out that this is disabled by default, and I should enable it in the "Startup options" menu, which I was eventually able to find in Settings->PC Settings.

But unfortunately, when I restart the PC and enter this menu, it hangs. It doesn't respond to the 7 or F7 keys, which should toggle the driver signing check, and it neither responds to enter to continue booting or ctrl+alt+del. The only thing I can do, is turn off the laptop using the power button. When I turn it on again, Windows starts as usual, without entering the menu, and still without the driver check disabled.

I must note I waited a couple of minutes to see if it just took a while to respond. After a while I thought I saw some flickering as if the screen repainted itself. But still no response to the keyboard.

I've searched, of course, but because of the sheer number of things that can go wrong during Windows Startup, I couldn't find my answer yet. Related to this menu, I've found Advanced startup options appear in blank, but it's is a different problem.

I also found Windows 8.1 Advanced startup options disappeared. This is also a different issue, but it led to command line commands which seemed to toggle this setting too. So I fired up CMD as administrator and tried them. Now the bottom-right corner of my desktop says 'test mode', but I still cannot install the driver.

Although I have some experience with earlier versions, the configuration tools of Windows 8.1 are quite new to me, and I have no idea how to troubleshoot this problem.

My computer is an HP Pavilion dv7 with an Intel Core i7, 6GB ram, running a registered Windows 8.1 Enterprise 64 bit.

0

I don't know if this is the answer, but at least it worked for me after a couple of desperate attempts.

First I tried to reboot and press F8 continuously to get into the startup menu. This, for some reason, didn't work at all. I couldn't enter the menu.

Eventually I rebooted using the command shutdown /r /o, which reboots and brings up the options menu. This was the same menu as I found in Settings before, so I was afraid it wouldn't work. But I tried it anyway, and this time the menu didn't hang, so I was able to toggle the setting.

I was able to install the driver (I still got the warning, but I could override it). And the AVR programmer now works fine.

Really weird. I didn't try the steps in my question just once, but quite a lot of times. So it's either a weird coincidence or a weird bug that it now worked after rebooting from the command line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.