0

After running:

homestead ssh

and logging into the VM everything looks okay until you're typing certain commands or viewing command results where the characters aren't rendered properly so you get output for ls that looks like this:

vagrant@homestead:~$ ls
←[0m←[34;42mprojects←[0m

Is there a way to get this to render these characters properly in Git bash on windows 8.1?

Also the cursor can appear in strange places if you run commands like:

mysql -uhomestead -p

With windows am I just forced to use Putty to get this to work properly?

UPDATE

It appears to be ANSI colour codes not being displayed. I've already added color.ui = true to gitconfig so not sure why this occurs unless Git SSH renders things differently? Since I get colour output when using the bash and but not using SSH.

UPDATE

Tried re-installing GIT to see if I had other options and noticed that I was given an option for using (tortoise)plink instead of OpenSSH. I downloaded the Putty plink.exe and provided its path, but homestead SSH still doesn't render the ANSI color code, and doesn't open Putty instead... not sure what was supposed to happen if you provided plink path, but assumed it would use Putty instead?

migrated from stackoverflow.com Feb 9 '15 at 9:11

This question came from our site for professional and enthusiast programmers.

0

Seems the easiest solution on windows is to use ConEmu as a wrapper for Git Bash and it takes care of rendering any ANSI color codes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.