20

The new version of Google Maps is unbearably slow for me; both at home and in work.

  • Both machines are Windows 7 64 Bit.
  • My work colleagues have similar specs and never notice any issues.
  • The sluggishness is in both Chrome and Firefox.
  • Clearing my cache has no effect.
  • Running the new version in Incognito mode has no effect.
  • Disabling extensions has zero effect (I don't have plugins installed on Firefox, as I mostly use Chrome).
  • It actually works "kind of OK" in IE 11.
  • If I switch back to the classic maps, everything is fine.

This has been as ongoing issue for months now. Is there anything that might be causing this?

3
  • Your article looks rather like a statement as a question, I would say ... Marked as "unclear what you're asking": Please clarify your specific problem or add additional details to highlight exactly what you need. – Leo Chapiro Feb 9 '15 at 16:05
  • 1
    @duDE My apologies. I've updated the question. Basically, I'm all out of ideas on this one and I'm looking to see if there are any other factors that could be causing this. – Wayne Feb 9 '15 at 16:07
  • classic maps has been turned off however there is now a "Lite" version which is basically classic maps support.google.com/maps/answer/3031966?hl=en – user451287 May 24 '15 at 8:45
14

It may be related to hardware acceleration issues.

For Chrome v36, try this (no guarantees about older/newer versions):

http://www.askvg.com/fix-slow-performance-issues-and-tabs-not-loading-problem-in-google-chrome-by-disabling-hardware-acceleration-feature/

1. Open Google Chrome web browser and click on Control button -> Settings option. Alternatively, you can directly open the Settings page by typing chrome://settings/ in Chrome address bar.

2. It'll open Chrome Settings page. Scroll down to bottom and click on "Show advanced settings..." link.

3. Again scroll down to bottom and you'll see "Use hardware acceleration when available" option present under "System" section. Uncheck the option and restart Chrome.

9
  • Wow. I wasn't expecting that. I disabled Hardware Acceleration on both Chrome and Firefox and it worked. Why would Hardware Acceleration being on cause this issue? – Wayne Feb 9 '15 at 16:14
  • @Wayne - Your hardware isn't powerful enough. – Ramhound Feb 9 '15 at 16:21
  • 1
    Definitely make sure you have the latest driver from NVIDIA - not from ASUS - installed. If that doesn't work, you can try the latest driver from ASUS. – njahnke Feb 9 '15 at 22:04
  • 8
    @Wayne: A GTX 660 ought to be more than powerful enough to handle some simple canvas stuff like Google Maps. The hardware is definitely not underpowered. – Reid Feb 10 '15 at 6:00
  • 1
    Consider using Bing Maps. It's much faster than Google Maps and AFAIKT, just as comprehensive. In the UK it even has OS Maps integration. – Iain Feb 13 '15 at 10:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.