4

On a website that generates PDF reports, Internet Explorer 11 tries to open the PDF file with the associated PDF viewer on my system instead of just saving the downloaded file. I want Internet Explorer to download the PDF file straight to disk. I do not want the PDF file opened in any PDF viewer nor in IE itself.

2

To change the default PDF open behavior when using a web browser:

In Adobe Acrobat\Reader Choose Edit—>Preferences Select the Internet category from the list on the left To display the PDF in the browser, check "Display in browser" To open PDFs from the web directly in Acrobat, uncheck "Display in browser

5
  • I tried your suggestions and lots of others that didn't work. forums.adobe.com/thread/1082459 forums.adobe.com/thread/1086608 The only solution for me was the above registry changes.
    – voidmain
    Jul 27 '15 at 20:03
  • Glad to see you found some help!
    – El Turner
    Jul 27 '15 at 20:22
  • No you misunderstood me. Your comment was of no assistance. Rather it was the registry changes that I posted below. Somehow the order of my comment on the page was moved below yours even though I posted first.
    – voidmain
    Jul 28 '15 at 13:48
  • I didn't misunderstand, I was glad that you found the help you needed... Even if it wasn't me that helped.
    – El Turner
    Jul 28 '15 at 13:51
  • You can flag the answer so it will stay at the top and people will know this was resolved
    – El Turner
    Jul 28 '15 at 13:52
1

Right click the PDF link, and click "Save Link As", or "Save Target As".

1
  • 1
    This does not work because the link is a javascript function.
    – jjz
    Feb 11 '15 at 22:40
1

Add the following content to a .reg file and merge it to the registry.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\AcroExch.Document]
"EditFlags"=hex:00,00,00,00

[HKEY_CLASSES_ROOT\AcroExch.Document.11]
"EditFlags"=hex:00,00,00,00

[HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\11.0\Originals]
"bBrowserIntegration"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Adobe\Acrobat Reader\11.0\FeatureLockDown]
"bBrowserIntegration"=dword:00000000

Note: the above registry modifications were working correctly up until 27-JUL-2015. It appears that a recent Adobe Reader update is bypassing the registry changes and once again the PDF file is being displayed in Adobe Reader instead of being downloaded. However, after applying the above registry changes, IE behaviour was restored to downloading PDF files rather than opening them in Adobe Reader.

0

Try shift-clicking the link, this will bring up a new window.

If your in-browser PDF viewer has a save function use that, or hit ALT-F to bring up the file menu pull down and use the Save or Save As function in Internet Explorer (in the new window).

As a last ditch effort to save the PDF, close your PDF viewers and web browsers, and temporarily uninstall your PDF viewing software. This will force the web browser to prompt a download without an applicable plugin or viewing software to load it.

I hope this helps!

0

You can do this by disabling Adobe PDF Reader add-on in Internet Explorer options

  1. Click on Tools & find Internet Options
  2. Navigate to programs Tab & find Manage Add-ons
  3. In the show menu select, All Add-ons
  4. Find Adobe PDF Reader in the add-on list
  5. Click on Disable at the bottom right corner & Close
  6. Relaunch the browser & it would ask you to save the PDF now instead of displaying

Disable Adobe PDF Reader addon

0

The registry location for this Adobe add-on seems to have been changed recently. If anyone is looking for a quick command line solution to disable it, here is a (slightly hacky) one-liner.

set "k=HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{CA8A9780-280D-11CF-A24D-444553540000}" ^
    && call reg add %^k% /f /v Flags /t REG_DWORD /d 1 ^
    && call reg add %^k% /f /v Version /d *

If you want to be able to instruct your CLI-phobic users to paste it in the Run dialog, or even in the new Win10 Search Windows box on the taskbar, use this variation that invokes the command interpreter:

cmd /v /c "set k=HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{CA8A9780-280D-11CF-A24D-444553540000} /f /v && reg add !k!Flags /t REG_DWORD /d 1 && reg add !k!Version /d *"

Change the /c to /k if you want the command window to stay open to read the output.

Tested only on Windows 10 1511.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.