6

I have recently completed a Zoneminder surveillance system installation at a remote location. The dedicated server is running Ubuntu 14.04 LTS and is currently connected to 4 IP Cameras (Hikvision DS-2CD2032-I) on the same subnet. The router is a Motorola Surf Board SBG6580-G228.

Now, I’m attempting to setup a Raspberry Pi to stream video from a camera at the remote location. My goal is to use Zoneminder for recording events and use the Raspberry Pi as a viewer for the primary camera. This is where I’m running into trouble. I can connect to Zoneminder and the Camera’s web-based management pages remotely, but for some reason I can’t view the camera’s RTSP stream.

I have port 554 open and forwarded to the camera I want to connect to. When I enter the RTSP address in VLC without the login credentials, I am prompted for them, so I know it is connecting on some level. However, once I enter the credentials, I receive no error, but also no video. I know the camera is working, because I can log into Zoneminder and see it.

Does anyone have any idea what I could be missing?

5 Answers 5

5

Just had exactly the same problem - I was trying to access DVR RTSP stream via VLC player and had no video but no error as well. It turns out that in VLC preferences you must switch Live555 stream transport from default HTTP to RTP over RTSP (TCP).

VLC > Tools > Preferences > Input & codecs > Network > toggle to RTP over RTSP

2
  • 1
    Didn't work for me
    – LeoColman
    Nov 4, 2017 at 16:14
  • Worked for me for Dlink camera
    – maxfridbe
    Apr 22, 2021 at 15:43
3

I haven't found an answer to my question (at least not any that I like), but I have found a work-around.

Based on heavyd's response, I Googled RTSP streams to learn more about how they work. As far as I can tell, he is correct, the video comes back over UDP, but not over predictable ports. That explains why the client can receive RTSP video streams on the same local network, but not remotely. The control channel (port 554) connects, but the returned video packets were being dropped by the router.

One suggestion I've seen is to open all ports to receive the stream. I suppose that would work, but that's an awful solution, in my opinion.

My work-around was to install OpenVPN, using the Zoneminder box as the VPN server and the Raspberry Pi as the VPN client. Once that was setup and the VPN tunnel was established they were essentially on the same network again, eliminating my port problem.

2

As Artanis said:

VLC > Tools > Preferences > Input & codecs > Network > toggle to RTP over RTSP

This worked for me, after so many days of searching I finally found relief!

Here is what I done for my UnionCam (Q2Pro):

  1. Download iSpyConnect (Opensource) (http://www.ispyconnect.com/default.aspx)
  2. Add a new "IP Camera with Wizard"
  3. If successful you will see the RTSP link; something like: rtsp://admin:password@192.168.1.105:554/user=admin_password=WEJwpbo6_channel=1_stream=0.sdp
  4. Set up port forwarding (I followed these steps: http://help.angelcam.com/general-guides-and-info/connecting-a-camera-to-angelcam/how-to-setup-port-forwarding-for-multiple-cameras)

  5. And finally use VLC with the above mentioned settings.

1

RTSP itself does not stream media, it is just a control channel used by clients to tell media server where and when to send media. You will probably need to open additional ports in order to get the video stream.

2
  • If RTSP is the control channel, it makes sense that the port would need to be open. However, I don't understand why ports would need to be open for the video stream --from the camera's point of view that would be out-going data. Although, if you have any port suggestions, I'd be happy to give it a try.
    – ks78
    Feb 9, 2015 at 22:19
  • 1
    The port you'll likely have to open is on the client side. Usually RTSP streams will come in over UDP, so there is no existing session for a router to know about. The problem is the ports get negotiated as part of the RTSP setup, and in theory could change for every session.
    – heavyd
    Feb 9, 2015 at 23:08
0

I also had a similar problem in using a Chinese IP camera with Zoneminder.I have overcome the problem by using Xeoma app to find the correct streaming address.Sometimes my findings may be useful for you .The details are in this link here

3
  • You should include the relevant information from the link, so users on this site, don't have to visit a third-party website unless they want to.
    – Ramhound
    Jan 21, 2016 at 13:08
  • And if the targeted page goes away, the answer will be much less useful.
    – blm
    Jan 21, 2016 at 19:32
  • I would like to see the response from ks78 who has originated the discussion.I don't like to answer the people who are just criticising with out upstanding the problem . Jan 23, 2016 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.