2

Windows 7 is always switch to Wifi connection once I connected to Wireless LAN. How do I prevent that ?

How can I force LAN as primary connection while Wifi is only used as backup ?

When I move around, I'll need Wifi but when I am at my desk, I preferred LAN for faster speed. Can we make LAN connection as default ?

How to use LAN as primary connection ?

  • 1
    This is somewhat dependent upon your device manufacturer and drivers. There may be an option to automatically disable WiFi completely upon connection to a wired network, and re-enable it upon disconnection from the wire. Alternatively, there's probably a hot key combination (Fn key plus one of the F keys) that will easily toggle the WiFi or "Airplane Mode" on-demand. Note that setting of auto-switch may override your hot key's capability. – Iszi Feb 10 '15 at 6:27
  • 1
    Depending on your device, the option to set the auto-switch may be in your BIOS/UEFI and/or in the "Advanced" tab on the Properties dialog for it in Device Manager. – Iszi Feb 10 '15 at 6:29
  • Thanks for hinting to the right direction - I knew there was an option to make LAN higher priority than Wifi. I just don't know which term to search for xD – Dio Phung Feb 10 '15 at 7:42
3

Thanks guys for pointing to the right direction.

I have found how to make LAN the main connection while still connected to Wifi, so that we can enjoy both mobility and performance. Here are the how-to steps:

  1. Click Start --> Run, type in ncpa.cpl It will open Network Connection control applet.

  2. Click Advanced --> Advanced Settings, under Adapters and Binding tab, move your LAN connection to the top. See the explanation: connections are listed in the order which they are accessed by network services. enter image description here full size

  3. To test it, I copy 15GB file over the network. So even though I am connected to Wifi, the copying is still using LAN bandwidth (which is way faster than Wifi). You can see the Network Utilization percentage. enter image description here full size

  • Not quite the fix I was suggesting, but that'll work too. – Iszi Feb 10 '15 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.