0

I have a strange issue with my network card in my pc.

My internal network adapter keeps getting an ip that does not come from the ADSL router's DHCP that I have connected to.

  • I have changed cable,
  • I have tried using a new router,
  • I have checked the automatic dhcp feature without any firewall and other strange setting on.
  • I have disabled and re-enabled the adapter.
  • I even inserted a new network adapter but even the new one is getting that same ip: 169.254.x.x.
  • I have disabled the ipv6 protocol and even put static ip in the range of my routers availability but even then I cannot open the router interface at 192.168.1.254.
  • I have un-installed all anti-virus agents and firewall services but keeps up the same!

My environment is Windows 7 Professional.

Let me mention that in the same problematic infrastructure of router/cable if i install a usb wifi dongle...works just fine! and the ip is correctly assigned with full adsl usage and web router access!

Does anyone have any idea what else to try?

migrated from serverfault.com Feb 10 '15 at 11:51

This question came from our site for system and network administrators.

  • 3
    you may have another DHCP server in your network. Could you connect your computer directly to the router and disconnect every other device from the router? – Dirk Trilsbeek Feb 10 '15 at 8:09
  • 2
    The IP address cannot be 169.256.x.x, that's not a legal IP address (no matter what the x represents). Perhaps you mean 169.254.x.x, which would indicate you aren't getting a DHCP reply. – David Schwartz Feb 10 '15 at 12:15
  • 1
    someone other than the OP changed the IP address in the question. Getting a 169-address indicates no DHCP at all, while getting some valid address would indicate a second DHCP server. Ideally the OP should confirm that the modified IP address is actually the one he is receiving. – Dirk Trilsbeek Feb 10 '15 at 14:52
  • @DirTrilsbeek it is only 1 adsl router cause it is a home network. – ckinfos Feb 12 '15 at 5:27
  • @DavidSchwartz u r correct the ip was mispelled and now edited. sorry for the inconvenience. – ckinfos Feb 12 '15 at 5:28
6

Your address cannot begin 196.256 as the octets (numbers) range from 0-255. Perhaps you mean an IP address that begins 169.254. (If so, please edit your question to reflect reality.)

a 169.254 address is indicative that the PC couldn't get a address response from a DHCP server. Typically in a SoHo environment this would be the router.

If you want to check the settings on the router you are going to need to set a static IP address on your PC. Use an address in the range 192.168.1.10 - 192.168.1.250 (do not change the first three numbers as they must match your router's IP address). The netmask will be either "/24" or 255.255.255.0. You don't need a gateway but it would be the router's IP address. DNS likewise, or set it to 8.8.8.8 for now.

You should then be able to contact the router, ping 192.168.1.254 or open the router configuration page in your web browser.

  • i have as mentioned in the question done the static ip...putting either the google's dns like 8.8.8.8 as u mention or the router ip that should at most time suite for getway. The result was still not able to communicate the web interface with the router! And the problem is more complicated because even a new adapter has the same behavior joined in a complete new router/cable that is known to work perfectly! – ckinfos Feb 12 '15 at 5:36
  • what i came up is One solution that i may have to try, yet, seems to be to load a live cd of some kind of Linux distro and try to see if the adapter is working. Propably a messy dhcp windows service?? a bad network driver(Although i have installed and unistalled a new one)? i will try to test and report the results. – ckinfos Feb 12 '15 at 5:37
  • @ckinfos you say you added a new network adapter. Silly question time: you're not confusing the installed NIC with one on the motherboard, are you? Do you see a link light on the RJ45 socket at each end of the cable? – roaima Feb 12 '15 at 11:36
  • i have 1 network ethernet adapter coming on the motherboard. It is Broadcom Branded and i have installed (for checking if the new connects correctly) a new 3com ethernet adapter disabling 1st the onboard one. Not even the new one is getting a correct range. I think it must not relate neither with the onboard network adapter neither the router neither the cable. Is it possible a service of windows not running? and which one may be? The wifi is working great on the same router!! – ckinfos Feb 13 '15 at 15:27
  • @ckinfos ...and the link light on the NIC socket on your PC? – roaima Feb 13 '15 at 17:47
0

Given that your comment under one of the answers that your Wi-Fi works well,

  • Try Disconnect from your WiFi network and enter the following commands in your terminal (run as admin same as elevated command prompt)
  • Type ipconfig /flushdns #This purges the DNS resolver cache.
  • Type ipconfig /registerdns #This Refreshes your DHCP leases and re-registers DNS names. (Note you are still offline)
  • Then Turn on Wi-Fi or plug in LAN cable. if it does not work, start with ipconfig /release and repeat the two commands above. See a similar question with answers
  • Welcome to Super User! Please read the question again carefully. Your answer does not answer the original question. DNS has nothing to do with DHCP. – DavidPostill Nov 11 '16 at 9:28
  • Welcome to Super User! Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise, tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Nov 11 '16 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.