Having issues with access point connecting my devices to the AP's wifi. Wanted to have better wifi coverage in my house, so I've extended ADSL router with AP LAN-LAN using ethernet cable. All devices unfortunately are not able to connect to the new AP's wifi, failing on "obtaining IP address". - I've switched off ADSL router's wifi to rule out channel issues / interference of two wifi. - DHCP is disabled on AP. - AP's wifi encryption was switched off as well, no help. - Devices are able to connect to AP's wifi, if using static IP only - AP's firmware was updated recently


Thanks in advance for any tips.

  • If your wlan access point is a router you either need enable dhcp or a dhcp relay option. Feb 10, 2015 at 12:47
  • enable it on ADSL router, or enable it on both devices? Feb 12, 2015 at 11:19

2 Answers 2


Problem is that your devices are not able to reach DHCP server.

From what I understand you have connected your AP to your ADSL router with a LAN cable between LAN port on ADSL to LAN port on AP. Is that correct ?

There could be multiple reasons for this not working.

  1. The LAN on AP has different IP address range than what you have on ADSL router. This will mean no data from ADSL will goto AP (and vice versa) thats why DHCP requests are getting dropped and devices are not getting IP address.

  2. DHCP on ADSL is disabled too.

  3. IP address of ADSL and AP are the same (like

Actually the right way to connect them will be to connect LAN cable from one of the LAN ports of ADSL to WAN port of AP. Make sure ADSL and AP have different network IP address (like for ADSL and for AP). Make sure DHCP is running on ADSL and also on AP.

  • Hi. That's correct. LAN to LAN (AP has only one port). Feb 12, 2015 at 11:05
  • That's correct. LAN to LAN (AP has only one port). ADSL has IP, DHCP enabled (relay disabled), Starting IP, ip pool count 100. AP has : static IP, gateway, DHCP disabled. Not sure about AP DHCP - should be disabled, not? AP should ask ADSL DHCP for the IP. Feb 12, 2015 at 11:18
  • If I enable DHCP on AP, it gives me many options. start IP, end IP default gateway (optional parameter) Feb 12, 2015 at 11:20
  • You have single port on your AP ? It this TP Link 3020 or 3040 ? Feb 12, 2015 at 12:50
  • Hi, yes it's single port AP : TP-LINK TL-WA901ND Feb 13, 2015 at 7:31

I had the exact same issue for quite some time. I use TP-Link Archer VR400 for both main and AP routers. The DHCP worked fine for all wired connections (to the AP as well) but not the WiFi clients of the AP. The problem was solved indeed by activating the DHCP relay in the lan settings. (enable DHCP, then change to DHCP relay with the IP of the base router as target) see configuration image here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .