7

How can I stop websites from overriding the keyboard shortcuts in Firefox?

e.g., if you go to Youtube, Ctrl+T no longer opens a new tab, etc.

It there a plug-in that will do that for me?

9

This is a focus issue....when you click on the flash player, focus is transferred from the browser window to the flash plugin.

This is a page on IBM's website with describes a method of creating a firefox extension that prevents hotkeys from being captured by flash here

Unfortunately, I'm unsure how effective this solution will be. I've seen on various forums people saying that there is no real way to prevent a plugin from grabbing the keyboard completely because of how mozilla handles plugins, and I haven't been inconvenienced enough to try to use the code I mentioned above.

It looks like the most convenient workaround would be MicTech's solution of clicking anywhere except the animation, and then proceeding with the shortcuts.

  • In this case, I notice that if I click outside of the video frame then my keyboard short cuts work again. An extra click will solve my problem for now. Thanks. – BIBD Jul 20 '09 at 1:14
  • This behaviour might be changing soon: bugzilla.mozilla.org/show_bug.cgi?id=78414 – Martin J.H. Nov 5 '13 at 21:23
3

I think, this is problem with Flash.

If you click on video player on youtube, then short-cuts stop working, but if you click outside video player, then short-cuts start working.

I have same problem, too.

1

If this isn't a flash issue as mentioned by MicTech, then it may be a JavaScript issue. I use NoScript, which disables JavaScript on a whitelist basis, so you can allow sites to use JavaScript if you a) trust them and b) require the javascript functionality while there.

  • +! - I've used that trick before. But some sites is use do require JS. Now, if I can find something that will selectively block the JS hotkey interceptors as well. – BIBD Jul 20 '09 at 1:15
1

The focus- and Flash-related answers are legitimate, and may help some people, but don't address the overall question raised by the subject: How to prevent sites from hijacking keyboard shortcuts. And the asker mentioned Firefox specifically.

Well, 11 years after the bug was filed, Mozilla has finally taken action on https://bugzilla.mozilla.org/show_bug.cgi?id=380637, which directly addresses this issue.

In current versions of Firefox (starting with v.58; I'm using v.59) there is a new per-site preference, but unfortunately it's problematic (as discussed in recent comments on the bug ticket): It prevents the Backspace and Del keys from working in the browser itself (e.g. to edit entered text), which is likely to be a deal-breaker for most people.

But you can experiment with the current implementation (and hopefully, access a fixed version in Firefox 60) by clicking the (i) icon in the Location Bar (or by pressing Ctrl-I, presuming you're on a site that hasn't hijacked that shortcut), going to the Permissions tab, and adjusting the Override Keyboard Shortcuts` setting:

Firefox screenshot

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.