4

I have a VMware Player VM located in a remote shared folder that resides on a Linux server. On the server side I have set up my file access permissions to the user ID used to open the shared folder, and I ran chmod -R 0777 * on the directory where the VMs are located.

Whenever I try to start a suspended VM, I get an error message that says:

Could not get snapshot information: Failed to lock the file

Module Snapshot power on failed

Failed to start the virtual machine

There are no stale .lck files on my VM's working directory, and I have made sure multiple times that the user ID I use to access the SMB share can create and remove files properly. I tried granting total access to all user IDs on the shared folder's properties, Security tab, and it didn't work.

3 Answers 3

4

Delete the *.lck folders in vmware folder of respective machine and it works fine.

3
  • 2
    The OP states There are no stale .lck files on my VM's working directory.
    – Jonno
    Feb 15, 2016 at 10:17
  • Helped me out..
    – Henry F
    Feb 18, 2016 at 19:02
  • @Jonno : Oops, I missed that part but probably it will help others in future. May be OP was checking in wrong directory.
    – Sejwal
    Feb 22, 2016 at 18:48
2

try to delete much space on the disk where the virtual machine is located, I had the same problem after I moved some big iso files to that disk where the VM was located, then I realized then when i deleted those iso's everything worked fine. I even tested that. I believe that problems are being see if your virtual machine is not preallocated and space left on the drive where the VM currently resides is less. I had observed that behavior already 4 , 5 times. In my case i had a VM with not prealocated disk with the maximum disk space 60 gig, and i had currently used only 20 of those. But the free space that i had left on my drive as only 3,5 gig. After i deleted another 6 gig from my ext3 partition where the Vm was located it worked again.

2
  • That's... probably it. Indeed I have very little space left on the disk where the VM resides. I'll move some files over to another disk, cleanup some files, and see what happens.
    – RAKK
    Feb 19, 2015 at 15:40
  • I had 1 or 2 GB space left which was apparently not enough. Sep 21, 2018 at 16:47
0

I fixed this problem by going to the directory path of the virtual machine, and double clicking the .VMX file, which is usually the same name as the virtual machine. This will create a new instance of the same VM. After that, you can just delete the old instance. Viola, nothing changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.