1

The XP SP3 workstation I used in workplace changed font rendering to ugly one in sudden(maybe after rebooting with chkdsk messages). How can I restore the font rendering setting back to normal?

screenshot of comparing between workstation with affected/ugly font (upper part), and other workstation that has normal font(lower part):

enter image description here

1
  • Wonder if your workplace actually paid for Custom Support.
    – Yuhong Bao
    Feb 12, 2015 at 4:00

2 Answers 2

8

Finally I found the root of issue is that, Microsoft pushed a faulty update(KB3013455) that breaks font smoothing(I don't know if this patch breaks font smoothing in NT6.x[i.e. Vista ~ 8.1] or not, but it does break NT5.1 based Windows). For those having this update installed should be removed in order to restore a working font smoothing look.

http://support.microsoft.com/kb/3013455

2
  • Thanks Roy! I had the same problem in windows 2003 and windows 2008. Please mark your answer as accepted (it's perfectly normal and in fact encouraged)
    – ndemou
    Feb 13, 2015 at 11:22
  • 1
    There's a fix now. See full info here: superuser.com/questions/876582/…
    – pgr
    Feb 24, 2015 at 9:11
2

Apparently not all fonts are broken but only some. It's better to substitute fonts with different ones. Security issues fixed by KB3013455 might be important ; )

I've used Microsoft's Power Toy to check which fonts look 'ugly'. And substituted Arial, Times New Roman and Courier New with Liberation alternatives.

I've also tried using fonts from Windows 2008 R2, but it didn't help. To replace the fonts I've used this approach

Copy the new font files somewhere to your system (i.e. C:\Temp\)

Then use the command line (Windows-Explorer won't work here since it automatically starts the install routine) to copy the files to c:\Windows\Fonts under a different name:

copy c:\Temp\tahoma.ttf c:\Windows\Fonts\tahoma_0.ttf
copy c:\Temp\tahomabd.ttf c:\Windows\Fonts\tahomabd_0.ttf

After that use the Registry-Editor to redirect the font names to the new files:

Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts and find the entries Tahoma Regular (TrueType) and Tahoma Bold (TrueType) and change it's values from "tahoma.ttf" to "tahoma_0.ttf" and "tahomabd.ttf" to "tahomabd_0.ttf" respectively.

Now you only need to restart your system and then the new font files are used.

1
  • Better solution but for me the rendering of the liberation alternatives produces a moderate result - not as ugly as the original but not good either: dl.dropboxusercontent.com/u/242368/fonts.png What's your situation?
    – ndemou
    Feb 24, 2015 at 10:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .