2

First I've done something stupid - I scheduled long disk check on boot, which I wanted to cancel, but I couldn't. So I used emergency power off. It didn't help, so I decided to wait. It didn't help, the scan caused BSOD and the system would not boot again. I used old Windows 8.1 USB to get to some recovery options. It made things much worse.

What was broken? Something with boot loader. My notebook uses EFI to boot, and for some strange reason it stopped to find the right EFI file.

To make long story short, I managed to fix MBR on special boot partition using Windows Recovery Disk (created from my Windows, which booted with EFI disabled).

Now I re-enabled EFI, system boots correctly, but 2 problems persist.

  1. Hibernation / Sleep don't work. Hibernation just turns off the screens, turns off bluetooth, but besides does nothing. PC is on, when I move the mouse I see logon screen. The sleep option makes some crazy shutdown instead. PC goes off, but when I switch it on again my user session is not resumed, all programs seems like suddenly terminated.

  2. System recovery option (F9 during boot) doesn't work. Recovery option in Windows doesn't work. F9 during boot does absolutely nothing. Recovery option in Windows says it has no installation media, even if Windows 8.1 installation (or recovery) USB is inserted and visible.

So basically I want to have hibernate / sleep back. Of course powercfg /H on and powercfg /H off don't help. I re-installed most chipset drivers, but it didn't help either.

No network adapter is set up to wake the PC up, I've double checked this.

I'm almost sure it has something to do with partitions, bootloader and MBR.

Here's my Disk 0 partition layout:

SYSTEM (100MB, FAT32, System, Primary Partition)
Recovery (900MB, NTFS, Active, Primary Partition)
OS (C:, 217.36GB NTFS, Boot, Page File, Crash Dump, Primary Partition)
Restore (20.01GB NTFS, Primary Partition)

I managed to create recovery USB using ASUS Backtracker. Somehow it got the data from my not working Recovery partitions. The recovery USB seems to work, shows the option to reset my PC to factory state, but I would rather wait with this.

Is there something else to try before "ending it all" and reformat whole disk? It seems like the system doesn't know where it should store data on hibernation and where the recovery partition is. IMHO all data on those partitions are fine, the problem is somewhere else, maybe in MBR? Maybe in some Windows settings? Maybe some flags should be set on some of system partitions?

The notebook model is ASUS G56JR.

10
  • Backup your user data and reinstall from scratch.
    – DavidPostill
    Feb 11 '15 at 11:45
  • You do understand what you describe describes a HdD that is about to fail, had sectors that lost data, and that's the only reason you have these problems currently right?
    – Ramhound
    Feb 11 '15 at 11:45
  • @Ramhound - it's almost brand new SSD (6 months). I doubt it's about to fail. My system worked perfectly well until I run chkdsk with some options on it. I made it to see what happens, tested for a friend whom I wanted to help (test first on my PC before I tell him to do this on his). Then I heard you shouldn't ever do surface scan on SSD. It was already too late, though I think if I waited in the first place instead doing emergency power off during scanning nothing would break. I read it's a known bug in chkdsk - it can damage data if you turn the PC off while scanning.
    – Harry
    Feb 11 '15 at 11:59
  • If you lost data by running chkdsk then the drive isn't healthy. Your friend isn't correct about the surface scan.
    – Ramhound
    Feb 11 '15 at 12:00
  • 1
    @Harry - The problem with chkdsk is that it really only reports the health of the filesystem and not the disk. I would just use the OEM branded tool to do that.
    – Ramhound
    Feb 11 '15 at 12:34
1

It was the hardware, but not the disk nor partitions fault. Probably the motherboard is damaged so the PC cannot wake up from sleep mode. What's important here - the attempts to use the broken sleep function are very harmful and dangerous. My system partition was damaged beyond repair twice when I tested STR feature. It's probably caused by performing hard reset during disk write operation.

I had some issues with sleep mode earlier on different PC, but they could be resolved by reinstalling the system and / or drivers. This one is 100% hardware fault.

BTW, the disk and the memory is 100% fine and tested with various tools. The data corruption I mentioned was caused by broken sleep mode.

To make myself clear: chkdsk did not break my system and it's safe to run on any disk. I also did nothing to break my recovery partition. It was broken due motherboard failure. Just a bad luck.

2
  • I have the exact same issue, it's a UEFI bug in the Asus laptop : superuser.com/questions/608022/…
    – Milind R
    Jun 18 '17 at 8:49
  • @MilindR : I contacted Asus support, they told me when I remove all partitions I'm out of luck, the only way to fix the laptop is to send it to them. I haven't done it though, it was not mine (it was my employer property) so I just left it like this. I'm not sure if I would buy this model again. Maybe I broke it with removing it's recovery partition, maybe it has firmware bugs built in. It's a big shame you can't download necessary tools and binaries from their site. I have no such problems with my old PC, it just works. BTW, the laptop cooling broke soon after this.
    – Harry
    Jun 23 '17 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.