13

I'm having trouble with my PC freezing, and decided to run Memtest. What happens is: no error is being revealed, but the test gets halted when it reaches 8:30 min (16% of total test). Does this mean something? What should I do?

9
  • Are you running MemTest86+ 5.01?
    – misha256
    Feb 12 '15 at 5:24
  • Memtest86 v5.1, is that is? If so, yes :) Feb 12 '15 at 5:42
  • 1
    Ok you're using a different version. I use this one: memtest.org. In any case, both versions share a lot of the same underlying code. When you run yours, is SMP (multi CPU/Core) mode enabled? That could absolutely be the issue. It's buggy and doesn't work with certain PC configurations.
    – misha256
    Feb 12 '15 at 5:47
  • I'll check tomorrow and leave feedback. Thank you for your attention! Feb 12 '15 at 6:02
  • Sorry, I could not find where that option is available : /, but I downloaded the v6. version of what I said and the problem persists. Feb 15 '15 at 16:04
20

I recently hit the same issue on Memtest 5.01 Release version. The test fails exactly at Step #7. At around 20-25% progress indicator.

If something similar is happening to you, the recommended solution is to not use SMP mode. I am guessing you did the the same thing as me. Hit F2 and enable SMP when the test starts. If that is not what happened and you do not see SMP enabled in the memtest86+ screen then you should try the other solutions recommended here.

Currently there is no known fix for this. Officially on memtest.org86+ only 5.01 exists as latest release as of this writing. If you are using a higher version it is likely an OEM but likely uses the same underlying base code with minor modification inheriting the issue.

Reference: http://forum.canardpc.com/threads/84663-Memtest86-is-freezing-while-running-test-7

When I ran the tests without SMP everything checks out. The only reason I investigated is because I find it hard to believe Hardware will be the most likely cause of issues so I would suggest trying different methods to confirm hardware failure.

I wasted half a day on this test and google brought me here first. Now I hope other can save that time to run test without SMP.

4
  • Same thing here, three years later. Running tests with SMP disabled works, but running with SMP enabled freeze at the exact same percentage in step 7. Apr 17 '16 at 17:40
  • 2
    I had this issue again in March 2016 - 5 years later and hit the same. Forgot about this whole thing. Hit google and did not find my answer at all?? wasted hours searching. Can we all upvote this please to save the planet the collective waste of electricity. thank you May 4 '16 at 10:48
  • Exactly this was the case with me too!
    – chrulri
    Aug 22 '16 at 19:56
  • I have a similar issue but at step #5.
    – einpoklum
    Feb 17 '17 at 15:55
2
+50

If Memtest freezes up, and doesn't recover (if you just let it keep running a while), then I can only conclude that this really is a good, strong indicator that the memory is not properly accessible.

Usually when there are memory errors, MemTest does not have a problem continuing to run, but it does continue, and so MemTest draws something on the screen. Having it completely freeze does indicate that the system's stability was affected, which is one of the possible symptoms of memory not working right.

This could be a bad memory stick, a bad motherboard, or maybe some other issue like a bug with a CPU feature. Disabling the CPU feature might help make Memtest work better in that case, and if so, may result in the system working better at other times (when you have a normal operating system booted up). There may be other possible causes; in theory, a damaged motherboard could cause errors when trying to access memory.

I would not trust this computer with any important data-handling tasks until I troubleshot further (which may involve replacing parts with other parts) to get to the bottom of the issue. I might tolerate the computer for something like playing a video, where a bit of inaccurate memory handling (loss) might be tolerable, for entertainment. If I cared about the presentation, like a business meeting where I am relying on the system stability so that I have a nice presentation, then I wouldn't be trusting this system. Understand that memory is needed to access data; bad memory can result in incorrect data being written, which could cause further troubles. Do treat this as a top priority until it really seems resolved.

And if you've been doubting whether there really is an issue or not, I'm interpreting your MemTest results to say yes, most certainly: there is. I'm not trying to say that I know exactly what is causing the problem, but I am confirming that something is wrong. Memtest did its job by conclusively telling you that.

4
  • It may help to add this information: My computer is freezing, approximately twice, three times per day. When it freezes, a loud noise comes on the speaker. Is it associated? Feb 15 '15 at 22:20
  • Speaker noise can be caused by all sorts of things, like interference in a wire, or a motherboard misbehaving (and maybe sending out weird/wrong/bad sound data out its sound ports). Likely related? Really don't know; there's lots of possibilities to that. Could be; very good chance that it's not caused by bad memory; maybe some other bad part. Really hard to tell since so many things can cause that particular symptom. However, freezing is often something that is quite commonly caused by bad memory. Likely related? Yes, high probability on that one. Worth checking out.
    – TOOGAM
    Feb 15 '15 at 22:27
  • 2
    You shouldn't "only conclude". There always a chance it's a MemTest bug, and in fact, several people have been encountering one lately.
    – einpoklum
    Apr 9 '17 at 22:01
  • 2
    I've hit the SMP-freeze issue with three different memory sets, all of the same properties (one RMA and one to check if RMA is a solution). It is either a bug in MemTest86+ or it's the CPU/Mobo which triggers this issue.
    – Daniel F
    Jun 12 '17 at 11:45
2

There's likely a bug with MemTest+ 5.01, see this question of mine from a while ago:

How likely is it that I've encountered a MemTest+ bug?

It may or may not be the reason you're seeing a freeze. It's still quite likely that there's an actual problem with your memory.

1

It's probably because there is a memory fault that even memtest can't deal with. If you have multiple sticks of RAM, remove all but one and run memtest again. Repeat with each RAM module so you can identify the faulted one.

1

Try remove RAM module(s), and clean the gold contacts with a dry sponge or eraser (rubber). Sometimes there is a thin film of oxidation, and the computer freezes randomly.

1

This is most definitely a bug with memtest86+ 5.01

I am testing a blade system which was freezing at 7%, this is with built in memtest from proxmox installer which is the dreaded 5.01.

Switching to SystemRescue (memtest86+ 5.31b-1) it works fine and does not stop at 7%.

Bug is documented (specifically in verion 5.01):

https://bugs.launchpad.net/ubuntu/+source/memtest86+/+bug/1876157


*** Enhancements in v5.31b : ***
I've started compiling many codes branches to release public builds again! Here is Memtest86+ 5.31b, with many bug fixes in the core functions.

Also there is updated Memtest86+ branch at https://www.coreboot.org/Memtest86%2B - several people told, that this branch does work, where original Memtest 5.01 doesn't, see
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=943752

---- Original bugreport ----
I ran it twice, and both times it hung at exactly 79% in the first test. Even fail safe mode hung exactly at that point.

Then I booted with the floppy image from memtest86+-4.10.floppy.zip and it worked fine.

Today I installed memtest86+_5.01-3ubuntu2_amd64.deb from Ubuntu 19.10 and that worked fine too.

The failing version is 5.01-3.1ubuntu1.

Memory configuration is 2 * 2 GB (F2-6400CL5-2GBPQ) and 2 * 1 GB (OCZ2G8001G) working in dual channel mode. CPU is Harpertown Xeon X5470 running at stock speed (3.33 GHz).

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: memtest86+ 5.01-3.1ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-28.32-generic 5.4.30
Uname: Linux 5.4.0-28-generic x86_64
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: XFCE
Date: Thu Apr 30 13:51:01 2020
SourcePackage: memtest86+
UpgradeStatus: Upgraded to focal on 2020-04-06 (24 days ago)
2
  • Please add further details to expand on your answer, such as working code or documentation citations.
    – Community Bot
    Sep 4 at 21:20
  • I've had issues with memtest too, wanted to test new 8GB dimms I got, no configuration worked and it seemed to always fail around the 4g memory hole. Turning on SMP just made it fail "sooner" (tbh I think it's the test that was twice as long, so sooner percent-wise), but it also failed sooner if I disabled the memory hole remapping in the BIOS. I ran a usermode memtest fine and the system is stable so far. Nov 7 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.