1

Problem: Applications that use Text-To-Speech (TTS) engine cause the speech to fadeout mid sentence. Reads current sentence of text then fades out after about 1-2 seconds only to return at the beginning of the next sentence only to repeat the same error/setting.

Replication: So this issue first arose with use of the beta Google Text-to-Speech 0.1.0 engine for Firefox. Having rushed to judgement I punished poor Google. Today when I was investigating my Windows 7's TTS engine (for unrelated event) I noticed an exact replication of the issues that had happened in Firefox from Google's TTS engine. Windows 7's TTS engine, called from Microsoft Narrator, had the same issue when randomly reading different things aloud.(So I'm assuming that Google was using my computers TTS engine and definitely not the case that there is a second TTS engine)

My Thoughts: After experiencing this I next thought that the sound card hardware, software or drivers would be a likely culprit. I do not have any software installed for my Sound Blaster X-Fi Xtream Audio hardware. There is some application though I don't believe it is a necessity (everything else audio-wise works perfectly). The drivers are up to date and working by account of Windows Device Manager. mini-QUESTION: can device manager be assumed 100% true here?)

Quick-Fix Went to the active device's sound properties and under advanced tab there is a setting for exclusive mode. I unchecked both "Allow applications to take control of this device" and "Give exclusive mode applications priority". Yes I figured out a work around/quick fix but would really like to know the root cause of the problem (I have my mild case of OCD to thank for this) and get it sorted out in case my quick fix decides to come back and remind me.

Any thoughts, suggestions or ideas would be greatly appreciated.

  • You say your drivers are up to date, but just to be super clear, do you mean with the Creative drivers or the MS drivers? – Dave Feb 12 '15 at 8:04
  • @Dave Yes indeed I do. I also went through multiple channels to have the correct drivers installed and still no luck. My apologies I was unfamiliar with the procedure of the website, thought I checked to automatically notify me when someone responds. Also I guess I had two different identities under the stack community but I sorted that issue out and have all under one now. – Paul Randleman Mar 30 '15 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.