I'm running Windows 8.1 x64 (Verssion 6.3, Build 9600). Starting yesterday and ever since (despite restarts and so on), my windows have been almost-constantly behaving as if they are set to "always on top." At first I thought this was limited to Google Chrome, until I noticed practically every window (Visual Studio, Outlook, Notepad++, HipChat, Remote Desktop instances) was behaving this way.

Following advice from this question (pressing ctrl+alt+esc to remove the "super state" from a window, restarting explorer.exe, etc) provide temporary fixes, but it doesn't take long for the problem to resurface again. Unlike that question, though, my problem is not caused by use of "Show Desktop." It just happens.

What on earth is going on? This is a very frustrating issue.

UPDATE: It very may well be Synergy that's causing my issue, not Widnows (as the KB update is not on my machines but it still happens, and force-closing Synergy from Task Manager makes the problem go away).

UPDATE 2: Since Synergy was my cause, I have selected an Answer for this post. However, as pointed out, if you don't have Synergy there are other potential causes of this issue.


Are you using "Synergy"? I have been following this problem since the first post, and I too thought it was a windows-update issue.

Closing Synergy from the Taskmanager solves the problem for me.

[Update] http://synergy.askbot.com/question/838/windows-81-window-focus-problem/

[Update 2] https://github.com/synergy/synergy/issues/4349

  • 1
    Closing Synergy from the task manager worked for me as well. And us Synergy users only recently just got over "won't send shift-modified keys over Synergy" bug that was around for months...
    – Scott
    Feb 17 '15 at 18:08
  • 1
    To readers: If you do not use Synergy, there are some additional advices.
    – miroxlav
    Feb 17 '15 at 18:21
  • 2
    I am accepting this as the answer, because it indeed was my exact problem (and turning off Synergy makes the problem vanish instantly).
    – Scott
    Feb 17 '15 at 20:43
  • The new version of Synergy solves the problem, be sure to download it from synergy-project.org/download
    – nizzle
    Mar 23 '15 at 21:09

Yay! I found my culprit: HScrollFun.exe (also named HScroll Application). It's part of the "ThinkPad Compact Keyboard with TrackPoint driver".

With my Lenovo keyboard's trackpoint, as soon as I scroll any page vertically or horizontally (by holding the center button), my windows start to have the "always on top" symptoms. It doesn't affect my laptop keyboard, only my external one. Killing the process fixes the issue.

All this seems to coincide with a Lenovo System Update that was installed on Feb 8th, but Lenovo doesn't appear to provide a good way to rollback this update, neither can I find an updated driver.

Solution at this point: Prevent this utility from running by removing it from the registry. Of course, I lose the ability to scroll with the trackpoint :-(

Location in the registry:

  • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run : "aHScrollutility"=...
  • and/or HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run : "aHScrollutility"=...

I must say HScrollFun is No Fun!


OK, so you say it is definitely not caused by KB3034196. Then I suggest more detailed diagnostic. Try keeping closed your tools or other utilities, even those running in notification area.

The possible candidates for the issue are:

  • Remote Desktop or TeamViewer (each has its own issues affecting rest of the windows from time to time. Some are related to keyboard, some to mouse. Few of them are serious.)

  • Winamp (see post in other forum)

  • HipChat

  • any other tool or utility you wouldn't normally suspect. Start with those typical for your computer, which only few other people use (so it won't be graphics card utility...)

When the situation with windows on top arises again and will become unbearable, decide to sacrifice comfort for next minutes or hours of your computer work and start quitting/killing all tools. Be sensitive when it will STOP happening. This way I've caught Remote Desktop and Team Viewer when they were doing their strange side effects.

If the problem is not resolved, try even booting without your favourite tools. Exclude them one by one or in pairs or triplets. (Then work a week without them etc.)

If you find the issue in clean Windows, then it is a problem, but from my experience it is unlikely. In most of cases, some tool/utility you are using is not written quite correctly and affects the whole system. Try finding it out for your PC configuration. I'm not sure if there is some magic to find the problem faster way. I was always going the hard way as I described above, but I got the results. Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.