0

I am using bitnami wamp on windows 7 running apache 2.4 and I am having a problem. The server address of the apache server shows ::1 instead of the expected 127.0.0 1

Is apache using ipv6 by default or what? In the wamp readme file, it says go to

http://127.0.0.1:80

or

http://localhost

When I do the 127.0.0.1 the browser tells me connection rejected but that is not the case for localhost. Localhost seems to work fine but I think it is using the ipv6 address ::1.

So why is my apache server address ::1 and not 127.0.0.1 and how do I resolve the issue.

Thanks.

2
  • It has bound itself onto the IPv6 address instead of IPv4. – Christian Isaksson Feb 13 '15 at 17:18
  • So how do I make it bind to ipv4? – Delali Feb 13 '15 at 17:19
2

I have myself never had issues with Apache listening on any IPv6 address, but this is what the apache docs say:

On some platforms, such as Linux and Tru64, the only way to handle both IPv6 and IPv4 is to use mapped addresses. If you want Apache to handle IPv4 and IPv6 connections with a minimum of sockets, which requires using IPv4-mapped IPv6 addresses, specify the --enable-v4-mapped configure option.

--enable-v4-mapped is the default on all platforms except FreeBSD, NetBSD, and OpenBSD, so this is probably how your Apache was built.

If you want Apache to handle IPv4 connections only, regardless of what your platform and APR will support, specify an IPv4 address on all Listen directives, as in the following examples:

Listen 0.0.0.0:80
Listen 192.0.2.1:80


You can read more here: http://httpd.apache.org/docs/2.2/bind.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.