0

I am having trouble using the awful.util.spawn call in my rc.lua config file for Awesome WM.

If I use: awful.util.spawn("xclock") it works.

But if I try awful.util.spawn("setxkbmap fr") there is no effect.

Specifically, I'd like to change the keyboard map to AZERTY.

I've tried using setxkbmaps by calling a file but it makes no difference. If I open a terminal after Awesome loads, the command works.
I've also tried creating (I didn't have one before, nor in my /etc/skel/ folder) a .xinitrc file containing setxkbmap fr, but it doesn't work either...

I am using Ubuntu 14.04 i686 with the latest AWM I think.

EDIT: I use the lightdm login which automatically detects my keyboard layout! EDIT: uing awful.util.spawn_with_shell seems to fix the problem...

0

It would appear that a solution is to use the awful.util.spawn_with_shell call instead of simply the awful.util.spawn.

I also eliminated the .xinitrc file in order to be sure that this works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.