3

Suddenly I see Google translate toolbar popping up at any some non-English website. I never had this before and want it removed. But where..?

I can't find anything under plugins or extensions, nor under installed programs.. So where is this malware hiding?

It looks like this:

enter image description here

I do have "Wictionary and google translate 7.2" add-on installed. But it's disabled. And I had this for a long time, while the google toolbar only occured a day or two ago, for unknown reason..

4

How do I turn off webpage translation?

Turn off webpage translation

If you don't want Google to offer webpage translation, you can turn the translation bar off. You can turn it back on at any time.

  1. On the right side of the Toolbar, click the wrench
  2. On the left side of the window, click the Tools tab.
  3. At the bottom in the "Translate" section, click Edit.
  4. To turn off the translation bar, uncheck the box at the bottom next to "Offer page translation when a webpage is not in [language]." To turn it back on, check the box.
  5. Click Save.

Now, when you visit webpages that aren't in your language, the translation bar won't appear.

Source Translate webpages:


How can I hide it?

Some websites display the Google Translate Bar on the top of the page when your browser is set to a different language than the website. This userstyle hides the translation bar on any domain.

Source userstyles.org - Hide Google Translate Bar [Firefox]


How has it been installed?

Since several months, Google offers also translator widget that you can include in your website and then instantly translate any page to another language. You can find it here: http://translate.google.com/translate_tools.

Troubles begin when your site or blog contains texts in more than one language. Say your browser's default language is English. As long as you stay on English pages of the website, things are OK. But if you, or your visitors, go to a page written in a language not matching the browser's language, at the top of your page will appear a large blue GoogleTranslate bar, nastily pushing down all the content on your page, trying to offer you a translation of that page to English. The bar is

  • intrusive (it pushes the whole content of your web page down)
  • uninvited (just like those pop-up windows before browsers started blocking them)
  • not needed (if someone wants a translation, they can choose it from the widget, from the Google Toolbar, or via another Google or other interface)

...

ultimately I discovered it is the work of a JavaScript program that runs after the page is rendered.

Source Instant web page translation with a Google Translate widget


Conclusion

The translator toolbar is added by website code. It can't be uninstalled.

Workarounds:

  • It can be disabled (as described above) or by using a user style (with the Stylish addon)

  • It can be blocked by disabling JavaScript (the NoScript addon is good for managing Javascript).

The addons are, of course for Firefox.

  • You describe to "turn off".. But why is it even there? How has it been isntalled, and how to properly uninstall it? – bretddog Feb 14 '15 at 19:04
  • Add remove programs, it was installed by an installer of another program as an optional addition – Ramhound Feb 14 '15 at 20:39
  • 1
    @Ramhound; Well, as I wrote; It's not present any Google toolbar or relevant program under add/remove programs. – bretddog Feb 14 '15 at 21:37
  • It's not a toolbar that's what caught me off guard, it's an interpreted feature into firefox itself – Ramhound Feb 14 '15 at 21:51
  • 1
    @Ramhound it is the website that adds it, using JavaScript. See my updated answer. – DavidPostill Feb 14 '15 at 21:59
1

I just added a '.google.com/translate' filter in AddBlock+ and got rid of those translations.

1

I was like you, and many others, angry with this injected javascript buggy "feature" from Google, having tried for ages to remove it.

Inspecting the code inside one offending webpage, I apparently could remove it for good.

In your web browser (in my case Firefox) you need to use some flavour of ADBlocker (in my case I use µBlock origin).

Whatever, go to this favourite adblocker and look for some kind of "add custom filters" options. Once located, add and apply these 2 rules (anyway, the first one should be the only needed, as far as I've investigated):

translate.googleapis.*/*/main*js
translate.google.*/*/*element*js

Once added, reload the offending page and tell us your success.

In my case it seems I've ditched this damned piece of Google code once and for all. OTOH, (and luckily), the official "Google Translate" domained page seems to be still working with all its functionalities, so my filter seems good.

As I said, try it and tell us your success.

Greetings.

0

If you're using the Firefox add-on 'Ghostery' it's easy to disable this translate bar - as easy as "on" or "off" in the Ghostery menu.

It should probably be this easy in 'AdBlockPlus' as well, but Ghostery was easier for me, so I'm satisfied anyway :) .

(you just have to visit a page where the bar appears, then disable it).

protected by Community Nov 3 '18 at 7:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.