-1

I have been trying to get VMWare Player/ VMWare workstation installed in KALI Linux for almost ages now. I might look a little exaggerating but I would like to quote it that way to bring about the level of frustration now that I have reached to :

I have tried almost every possible relevant link and the solution mentioned there in to have my problem solved and finally get either VMWare Player/Worskstation working, but have found only more frustration instead of any success.

My system specifications and things I have already tried out :

  • My OS is 32-bit KALI Linux kernel 1.1.0(lsb_release -a on my system gives :
    No LSB modules are available.
    Distributor ID: Kali
    Description: Kali GNU/Linux 1.1.0
    Release: 1.1.0
    Codename: moto

  • uname -r on my system is : 3.18.0-kali1-686-pae
  • VMWare Player version I have is VMware-Player-5.0.4-1945795.i386.bundle
  • VMWare Worksatation version I have is VMware-Workstation-Full-7.1.4-385536.i386.bundle
  • I have already run apt-get update umpteen number of times.
  • I have already done apt-get install build-essential and now if I do it again the output is :
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    build-essential is already the newest version.
  • As suggested in some places, I have already tried apt-get install build-essential linux-headers-3.18.0-kali1-686-pae and I get the output as the same as above, stating that it is already the newest version.
  • As suggested in some places, I have also tried this with some minor changes depending on my directory structures:
    cd /lib/modules/$(uname -r)/build/include/linux
    sudo ln -s ../generated/utsrelease.h
    sudo ln -s ../generated/autoconf.h
    sudo ln -s ../generated/uapi/linux/version.h

    So currently doing a
    /lib/modules/3.18.0-kali1-686-pae/build/include# ls -la
    shows that I have the required symlinks, (the below is the symlinks I now have)
    autoconf.h -> ./generated/autoconf.h
    utsrelease.h -> ./generated/utsrelease.h
    version.h -> ./generated/uapi/linux/version.h
  • I have rebooted my system after each of these updates.

I need some desperate help here. Is there any thing else that needs to be done to get VMWare Player/Workstation working on my system ? As of now if I run either of them I get the below :

Unable to start services.

See log file /tmp/vmware-root/vmware-modconfig-8692.log for details.

0

I'm using 3.18.0-kali1-amd64. I also had a problem with vmware-player 6.x. Uninstalling 6.0.x and installing 7.0 fixed the issues for me.

vmware-installer -l

sudo vmware-installer --uninstall-product vmware-player

sudo ./VMware-Player-7.0.0-2305329.x86_64.bundle

I think the recent update to kernel 3.18 is just incompatible with version 6 or less. About workstation I am not sure, since I just use the player.

  • am afraid.. this did not solve the problem either. – qre0ct Feb 18 '15 at 4:32

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.