5

TL;DR: I’ve tried everything to disable adaptive brightness with no luck. Brightness changes according to what’s on screen.

Recently I bought a Dell Inspiron 3542, built on the Intel i7-4510U with Intel HD4400 graphics and also an nVidia 840M. The laptop is running Win 8.1.

My problem is that, when the laptop is running on battery, I can’t disable adaptive brightness, no matter what I try.

  • I have disabled adaptive brightness in the windows control panel, under advanced power plan settings.
  • I have disabled adaptive brightness in Intel’s graphics control panel. Ditto for nVidia.
  • I have disabled the Sensor Monitoring Service under windows services.
  • I’ve even tried uninstalling Intel’s and nVidia’s drivers.

When the laptop is plugged in, there’s no adaptive brightness. When the laptop runs on batteries, adaptive brightness kicks in.

I should note here that the screen brightness changes according to what is displayed on the screen, and not according to lighting conditions.

Of course the laptop’s drivers are updated to their latest versions. Even the BIOS is updated to the latest version.

I thought this would be a Windows problem, so I tried running Linux. Still the same. The screen will dynamically adjust its brightness. So it’s not a Windows issue. Maybe it’s the Intel driver exhibiting the same behavior on both OSes? (long shot)

Could it be the laptop screen has dynamic brightness built-in? Is there even such a thing for laptop screens? The screen is the LP156WHB-TPA1, made by LG Display Co. I’ve checked on the internet but can’t find any info on such a feature, if it exists.

Any help/ideas/suggestions with this issue will be most appreciated!

Thank you.

  • I know Intel has this feature in its "graphics properties" on Windows, though I've never seen this behavior on Linux. If it also happens in the BIOS, it may be done at a lower level and you won't be able to change anything about it via the OS, so look for a BIOS option. – user256743 Apr 29 '15 at 23:41
0

Try rolling back the display driver to the previous version.

Control Panel
  > Device Manager (opens a window) 
    > Display Adaptors 
      > Intel(R) HD Graphics 4400 (double-click) 
        > Driver (tab) 
          > Roll Back Driver.

It worked for me.

0

I've looked around the web and there appear to be several possible causes and solutions to this problem depending on your Windows version and hardware. Here's a compilation of how to turn off adaptive brightness.

  1. Go to Power Options > Display > Enable Adaptive Brightness > Set it to Off in both places

enter image description here

  1. Go to AMD Catalyst Control Center > Power > PowerPlay > Uncheck the "Enable Vari-Bright" box

enter image description here

  1. Go to the Intel Media and Graphics Control Panel > Power > Disable Intel Power Saving Technology

enter image description here

  1. Go to Services > Disable the Adapative Brightness service

enter image description here

  1. In regedit:

    Go to HKEY_LOCAL_MACHINE\Software\Intel\Display\igfxcui\profiles\media\Brighten Movie and change ProcAmpBrightness to 0

    Go to HKEY_LOCAL_MACHINE\Software\Intel\Display\igfxcui\profiles\media\Darken Movie and change ProcAmpBrightness to 0

  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Feb 5 '18 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.