9

I have a late 2014 Retina MacBook Pro. I run Windows 8.1 via Boot Camp with the latest drivers.

It worked fine for quite awhile as a standalone setup. Recently I started using it only with an external monitor connected via HDMI. I used it that way for a few weeks. Today I unplugged everything from it and am attempting to use it as standalone setup again.

The first time it booted, I was using it for about 2 minutes and then got a rare 8.1 blue screen with the result being a DRIVER_POWER_STATE_FAILURE or something like that.

When I attempted to reboot, it went to the “loading circles” for Windows but then just a black screen. Nothing seemed to make the black screen go away. I force booted again with the same issue. Then I did it again with the MagSafe power connector unplugged, and it worked fine. Every time the power connector was plugged back in, the screen went black. This was infinitely repeatable.

I Googled around and found that one of two or both of the following options “worked” for people that had this happen:

  1. Reset NVRAM.
  2. Reset the SMC/power controller.

I have tried both numerous times and I’m fairly sure the SMC reset is successful when you see the MagSafe LED change to green and then back again after releasing the keys. This changed nothing for me.

I also tried updating the NVidia drivers—which someone else mentioned as fixing it—and repair installing the Bootcamp drivers, but neither helped.

Windows does boot into safe mode correctly, even with the power connector connected, so it seems to be a Windows driver problem. Mac OS X also boots and works fine with the connector connected.

Does anybody have any other ideas? At the moment I cannot use this machine other then not plugged in. So I can use it until the battery dies then have to wait for it to charge again before using it which is not ideal.

13

I finally found another post on another site with the exact problem and solution that fixed it for me.

Apparently there's a separate brightness setting for the screen when it's plugged in vs when it's not. The issue was the 'plugged in' version of the brightness setting was all the way to the lowest (black). Safe mode must have worked because the boot camp drivers don't run in that case, but I'm not sure why OSX worked.

Either way, I hope this can help anybody else who ends up in this same predicament.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.