1

I'm trying to run the Netflix Modern app on my PC running Windows 8.1. To be clear, this is the app that you can install in the Modern interface using the Microsoft Store. I'm not trying to run Netflix in a web browser. Note that it does work in a browser, it's important to me to get the Modern app working because this PC is for a home theater.

Every time I open the app, it gets stuck at the loading screen with the Netflix logo and the dots moving in a circle below it. Sometimes it crashes after sitting at that screen for several minutes, but not every time. There's no error message or any other diagnostic information that I've been able to find.

My system is fully up to date. Here's what I've already tried:

  • Installed all system updates
  • Uninstall and reinstalled Netflix
  • Ran (and passed) network diagnostics
  • Turned off Windows Firewall
  • Ran WSReset.exe as an administrator
  • Booted up after disabling all startup items

So far, nothing has fixed it. Netflix support has been absolutely no help.

Does anyone have any ideas on how I can fix this?

edit 1:

I found an error message in Event Viewer, under Custom Views / Administrative Events:

Faulting application name: Netflix.exe, version: 2.9.0.29, time stamp: 0x53e95fca
Faulting module name: twinapi.appcore.dll, version: 6.3.9600.16384, time stamp: 0x5215d806
Exception code: 0xc000027b
Fault offset: 0x0000000000056960
Faulting process id: 0x1614
Faulting application start time: 0x01d049ad8cab0f33
Faulting application path: C:\Program Files\WindowsApps\4DF9E0F8.Netflix_2.9.0.29_x64__mcm4njqhnhss8\Netflix.exe
Faulting module path: C:\Windows\System32\twinapi.appcore.dll
Report Id: d6e3fd1f-b5a0-11e4-82ea-001bdc0f3779
Faulting package full name: 4DF9E0F8.Netflix_2.9.0.29_x64__mcm4njqhnhss8
Faulting package-relative application ID: App

Unfortunately I don't know what this means.

edit 2:

A lot of sites suggested that fixing permissions of certain key directories and registry entries can fix this kind of issue. I checked the permissions on all of them and they are correct, which I expected. I certainly haven't gone dicking around with Windows' default permissions on this system, so that doesn't seem to be the cause.

edit 3:

Tried executing 'sfc /snannow' as an administrator, no dice.

  • Do other Windows Store applications work? – Ramhound Feb 16 '15 at 3:40
  • Yes, most of them work. However, several don't and crash immediately after opening them. So far I've found that Calculator, Calendar, People, and Money will do that. Also, if I try to search for something in the Store app it will crash. – GuyGizmo Feb 16 '15 at 5:54
  • Have you changed anything from the default behavior? If "Change PC Settings" crashes then either UAC is disable or you have a system integrity issue. – Ramhound Feb 16 '15 at 13:03
  • Change PC Settings / the PC settings modern app is working correctly. There's a lot of configuration I've done in setting up this system, but nothing that I can think of that should affect modern apps like this. Certainly nothing affecting permissions (which a lot of sites have suggested can cause this sort of problem), and UAC is not disabled. – GuyGizmo Feb 16 '15 at 16:58
  • Alright. If Change PC Settings works then it means Modern UI applications should work. If the default applications are not working run DISM and SFC. – Ramhound Feb 16 '15 at 22:32
1

I have exactly the same issue. I've tried all of the remedies you mentioned and more. (Including fully formatting my drive and reinstalling windows 8.1).

I found that the app works when widows thinks the network is "public", but not "home". I haven't confirmed "work" networks, but I think they do work.

So open your charms bar (dumb name... Slide the drawer out on the right side of the screen) and tap the WiFi button and forget your current network and then rejoin it but when it asks if it should discover network devices say no.

Edit: apparently you can avoid forgetting and rejoining your network by right clicking your network in the list of available network while you're connected and choose "turn sharing on and off" and then select "no don't share". I haven't confirmed this works, but it should.

I'm not satisfied with this as a real fix for the problem, but as an answer to your question this should get the Netflix app working.

If I find any more information about this I'll update my answer.

UPDATE:

So I found my private network settings had network discovery turned off, and i could turn it on but the setting would not stick even after saving. I did some research and found this article http://notestoneunturned.blogspot.com/2013/05/windows-8-will-not-save-network.html Following the instructions to locate the setting it also mentions this link https://social.technet.microsoft.com/Forums/windowsserver/en-US/5f8f9677-4a55-4e19-9843-b4c71aab93b1/network-discovery-keeps-turning-itself-back-off-?forum=winserverPN I had my DNS service disabled (on purpose, i'll explain below) and after turning this service back on I am able to turn network discovery back on and netflix works even when my network is set to private!

I normally disable the DNS service to allow hostsman (hosts file manager program) to help me block advertisements. Since this doesnt seem to be a very healthy thing to do on my system I will try and find an alternative to reduce advertisements.

-2

If you use a N or KN version of windows you won't have media player installed. This can cause the loading of a title to halt.

Check this to see more, or go to the windows webpage and dl the tools.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.