1

I tried to install Linux Mint 17.1 MATE 64-bit edition on my asus laptop, which had installed Windows 8.1.

I put CSM (Legacy BIOS) enabled, Secure Boot disabled, and boot with my Live CD USB (created with pendrivelinux Universal USB Installer). Already on the desktop, I chose to install Mint alongside with Windows. Once the installation was finished, I restarted the laptop and got into the BIOS.

The problem is basically that the Windows Boot Manager doesn't appear among the boot options, and Grub2 neither. I think that I changed something in the EFI partition by installing Mint on non-EFI mode (I thought that live session would have installed a Grub efi file in this partition, but it installed the common cfg file). The HDD has a GUID Partition Table. I checked the partitions and I found that the EFI partition has Linux File System as type and it's mounted as BIOS reserved boot area. I tried to mount this partition back as EFI System, but I just got an error related with sbdisk:

Error setting partition type: error setting partition flags on /dev/sda1:error spawning command line 'sgdisk--typecode 1:(code of EFI >System goes here)" "/dev/sda"': Failed to execute child process "sgdisk"
(no such file or directory)(g-exec-error-quark,8)(udisks-error-quark,0).

Right now, I'm considering several options:
1. Boot Ubuntu 14.10 x64 with my USB and try Boot Repair or something else (I hope this repairs the partition correctly).
2. Repair the EFI partition with some tool on Linux Mint Live Session.
3. Install Linux Mint or Ubuntu in my 24 GB SSD and pray for a good installation. If it works fine, I will use Linux as OS System while I look for a solution to the HDD issue.

Well, that's all I can say. If you need more information please just ask me.

Thanks in advance and sorry for my bad English.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.