I have an Acer Aspire Switch 10 and I want to boot with a USB stick or a DVD-reader.

I only can boot with a Windows 8 instal disk in it, having an EFI file on the DVD. With a recover USB stick (made under Windows 8) it works also ok. If I try with another EFI file it won't work. I think it must be an specific Acer or Microsoft EFI file. And I don't know how to make or edit it.

It won't work means for me when you boot from a USB stick or DVD it is not visible in the boot menu. I have a stick with YUMI on it and it works on all my other PC's. I want to do a virus scan undependable of its own windows and I want to make an image of the system as it is now.

I tried several ways of installing the EFI BIOS but I can't get it working.

The secret to getting Windows 10 on this device is to boot with an OTG USB adapter. USB from the keyboard doesn't work. I pulled my hair out for quite a while before I tried an OTG micro USB adapter directly in the tablet and not standard USB in the keyboard port. Still need to use RUFUS to create a GPT patirion scheme for UEFI computer, formatted for FAT32 along with a 32-bit version of Windows 10.

  • 1
    It's very odd that OEM installations are 32-bit and, seemingly, the Switch 10 cannot boot from a 64-bit EFI file - since it has a 64-bit CPU, according to my OEM 32-bit Windows... I wonder whether there's a way around this to run a 64-bit version of Windows or (more likely) some other OS. (I know 64-bit is a bit incongruous with the small RAM, but still) – underscore_d Jun 30 '16 at 18:32
  1. Go to BIOS settings with F2
  2. Add the .efi file to the trusted UEFI files by selecting it and naming the option to whatever you want.
  3. Enable F12 boot menu.
  4. Exit saving changes.
  5. Tap F12 until you get boot menu.
  6. You will see your boot option there.

Please look for the spots I mentioned. I only jumped true and gave pointers, and yes it works for the Aspire Switch 10 E too.

  • 1
    Well, this is weird, since my Switch 10 SW5-012 has all dropdowns in the Security tab disabled (just shows the text), and tapping the green headings like "Erase all Secure Boot Setting" also does nothing. I must have a more locked-down firmware than you did, somehow, and updating my original 1.18 to the latest 1.20 doesn't change anything. – underscore_d Jun 30 '16 at 18:30
  • 4
    Many of the firmware (BIOS) options only become editable after you set a firmware password. Otherwise, most of it is locked out. – Olivier Jan 5 '17 at 17:08

UEFI is a more secure replacement for BIOS; see http://en.wikipedia.org/wiki/Unified_Extensible_Firmware_Interface. It is so secure that it prevents booting from media with an incorrect 'signature', but can be adjusted to turn off security features so that you can boot from legacy media.

If you wish to use the legacy boot media you have, see Acer's directions for that at http://acer.custhelp.com/app/answers/detail/a_id/27045/~/changing-bios-mode-from-uefi-to-legacy. There's more information at http://www.tomshardware.com/answers/id-1875018/change-uefi-legacy-bios.html and http://www.howtogeek.com/175234/how-to-use-an-antivirus-boot-disc-or-usb-drive-to-ensure-your-computer-is-clean/.

However, you can generate UEFI-compatible media with some utilities, such as Macrium Reflect Free, http://support.macrium.com/topic.asp?TOPIC_ID=5133, and Kaspersky Lab advertises the "World’s First Anti-Malware Product for UEFI",http://www.kaspersky.com/about/news/product/2013/kaspersky-lab-presents-worlds-first-anti-valware-product-for-uefi.

Please let me know if this resolves the issue.

  • The (or at least my) Switch 10 does not provide the "legacy boot" (i.e. BIOS) mode to which you linked. – underscore_d Jun 30 '16 at 18:11

I managed to boot the Windows 10 USB image by pressing F2 repeatedly while the BIOS screen appears and set the boot device to the USB device.

  • 1
    I did this, putting both USB HD and CD/DVD options above "Windows Boot Manager" (i.e. the OEM EFI for Windows), and the Switch 10 neither boots from the DVD nor even shows it as an option in the F12 boot menu. Weird... – underscore_d Jun 30 '16 at 18:12

protected by Community Jul 17 '17 at 10:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.