29

When you browse to a non-https site, the http:// portion of the URL is hidden. Example:

enter image description here

However, on https pages it will automatically prepend the https://, even if you don't include it (which is a good thing). Example:

enter image description here

Is it possible to force the http:// to show, and automatically prepend it to the beginning of a URL if it's missing?

4
13

Since Chrome 83 there is an omnibox-context-menu-show-full-urls flag that enables showing full URLs in the omnibox.

chrome://flags/#omnibox-context-menu-show-full-urls
  1. Copy and paste the URL.
  2. Select Enabled.
  3. Relaunch the browser.

Now you'll see the full URL in the address bar:

Chrome omnibox


For Chrome 82 and older:

The easiest solution now is to just to download the Suspicious Site Reporter extension from the Chrome Store. And that's it.

As we can see in the source code, the protocol will not get hidden if this extension is installed:

Chromium source code Chromium source code


Previously, setting the omnibox-ui-hide-steady-state-url-trivial-subdomains flag was the easiest way to show the "https://www." back again, but it has been removed as of Chrome 76.

chrome://flags/#omnibox-ui-hide-steady-state-url-trivial-subdomains

chrome://flags/#omnibox-ui-hide-steady-state-url-trivial-subdomains
3
  • Thanks, I installed it and from inspecting its background page for ~20 minutes while browsing it doesn't appear to make any network requests (unless you click it and submit a report), so I guess this is a fine workaround. Out of curiosity, how did you come across this solution? From your screenshot it looks like you ctrl+f'd for that exact variable name
    – Jon
    Nov 26 '19 at 22:38
  • I was browsing the buganizer looking for possible solutions and came across this and this comment. Before I also tried asking if it was possible to renew the flag (it's just a matter of changing one number), but I didn't get any response... Nov 27 '19 at 7:19
  • 2
    NOTE, in addition to enabling the flag/experiment I had to right click in the URL bar and select "Always Show Full URLs"
    – HaggleLad
    Oct 17 '20 at 13:21
10

Just for future reference, in the current chromium version you need to disable both of the following flags in order to get the full URL:

chrome://flags/#omnibox-ui-hide-steady-state-url-scheme

chrome://flags/#omnibox-ui-hide-steady-state-url-trivial-subdomains

Edit: See above answer

1
  • 6
    It seems these flags disappeared with Chrome 79. Dec 12 '19 at 4:48
6

You can navigate to chrome://flags/#omnibox-ui-hide-steady-state-url-scheme-and-subdomains and disable Omnibox UI Hide Steady-State URL Scheme and Trivial Subdomains.

3
  • I tried that but I still don't see the http when I browse to http.badssl.com (even explicitly typing in http://). Does this flag still work?
    – Jon
    Sep 5 '18 at 19:30
  • 6
    At the moment it seems to only show https:// again. http:// is still hidden.
    – Yani
    Sep 6 '18 at 10:17
  • 1
    chrome://flags/#omnibox-context-menu-show-full-urls and then right click location bar and select always show full urls is the only thing that works right now.
    – user643011
    Sep 17 '20 at 7:10
3

As a work around, you can drag the icon in the left side of the url (the i with a circle around it for an http address or the lock symbol for an https address) into the url box and drop it. That will show "http://" again as part of the address.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.