37

When I open an Excel file from Windows Explorer, I always get a second Excel window as well. Annoyingly, when I close it, it doesn't close, but the other window does!

This seems to be a common issue:

How can I stop this second window appearing?

  • techwalla.com/articles/… This link helped me out – Standin.Wolf Aug 25 '17 at 7:47
  • 2
    File > Options > Add-Ins > [on the bottom] Manage: COM Add-ins > Go > disable MySQL For Excel – Alaa M. Apr 25 '18 at 10:16
  • Check out the most voted answer provided by Girish M in the linked post. – SIM Feb 28 '19 at 12:13
31

This can occur due to corruption in a personal macro workbook (%appData%\Microsoft\Excel\XLSTART\), and removing PERSONAL.XLSB from this folder caused the problem to go away.

I had to export each of my macro modules to another folder, then after removing PERSONAL.XLSB, record a new macro stored in my "Personal Macro Workbook" (which recreated PERSONAL.XLSB), then on the Developer toolbar, click "Visual Basic" and import the macro modules again.

All the shortcut keys and descriptions were maintained, but more importantly, I didn't get a second copy of Excel opening every time I opened a worksheet from Explorer.

  • 2
    I had to get rid of my old PERSONAL.XLSB and then copy and paste the macro content into a new one, created by Office 2016. – Adam Nofsinger Nov 20 '15 at 22:52
  • 1
    Removing this file also resolved the issue for me. Will keep an eye on the folder for a while and make sure it doesn't happen again – SimonC Mar 21 '19 at 10:48
28

My extra window turned out to be a problem with add-ins. In Excel 2016, here's how to fix that:

  • Open Excel.
  • Go to File > Options.
  • Click on Add-ins.
  • Look at the Active Application Add-ins (so alliterative!)
  • At the bottom of the dialog, in Manage, set the dropdown to COM Add-ins and click Go...
  • Uncheck the things you don't need.

In my case, there were three COM add-ins active:

  • MySQL For Excel
  • DriveForOffice [Google Drive add-in]
  • Microsoft Excel Code Compatibility Inspector

I left DriveForOffice but disabled the other two, and my extra window stopped showing up.

  • 1
    Fixed it for me... as well as fixing an issue with always prompting to save unchanged worksheets. I also had MySQL for Excel, and a couple of add-ins related to Visual Studio. – omatai Oct 16 '18 at 21:50
  • 10
    The "MySQL for Excel" add-in was specifically causing the extra sheet on my machine. Thanks for the tip! – MikeB Oct 18 '18 at 18:29
  • 3
    Judging from my own experience and those already noted, I suspect that the guilty party is MySQL for Excel, since it appears twice in the answer and comments, and is also in my own list. The other two COM add-ins in my list were Team Foundation for Excel and Visual Studio Tools for Office Design-Time Adaptor for Excel, neither of which I have ever used. Since bothwere instqalled last year, I suspect that neither was involved. – David A. Gray Jan 10 '19 at 3:41
  • 2
    whats the connection between opening two excel windows and MySql? – user9623 Feb 2 '19 at 20:55
  • I started noticing this issue after connecting to a MySQL database using the Add-in. The issue stopped after I disabled it. – xinthose Apr 25 '19 at 13:23
8

I had the exact same problem in Excel 2015 for quite a while, and when I hid the Personal.xlsb workbook, a blank page would open instead and I couldn't close that one without closing the file I actually wanted open.

But I finally found a solution! My problem was that I had a Personal.xlsb file in an alternate location, and for some reason a search of the C drive wasn't returning a match for that file name. My location was the same one that Amber mentioned above, but I wanted to share how I found it in case someone else has a different location.

The solution is to find the real location of the Personal.xlsb file so you can delete it. To do that, open excel and switch to the Personal.xlsb file. Now select the "File" tab on the top left which will load an "Info" page. On the right side of the information on that page there is information such as "Properties, Related Dates, Related People, and Related Documents." Directly under Related Documents is a hyperlink that says "Open File Location." Click this hyperlink and excel will open the true location of the Personal.xlsb file regardless of where your particular installation has placed it.

Now close Excel, delete the Personal.xlsb file, and reopen Excel. It should open only the file you want and a second window will no longer appear. From this point on, I expect other tips online about creating/deleting/showing/hiding the Personal.xlsb file will work as expected. But I have left it deleted and Excel is finally loading as I expect.

  • 2
    "switch to the Personal.xlsb file" - how??? – tbone Oct 4 '16 at 15:39
  • tbone: you can go to the View tab, click Unhide, and select personal.xlsb in the popup dialog. – Amit Naidu Mar 21 '18 at 17:16
5

I had this issue as well. Thought it might be related to my PERSONAL.xlsb file like so many mentioned. However, it had always been successfully hidden up until recently.

I went to the XLSTART folder to see if my personal workbook was indeed in the wrong place. It was there so I tried deleting and recreating it to no avail (just a big pain in my butt with the amount of macros I have).

I went back to the XLSTART folder and saw there was also an add-in file, something I had to install for work. I deleted this file and restarted Excel - no extra window! PERSONAL.xlsb stays hidden too. Not that this is everyone's issue but it was mine

  • 1
    Can you tell us what the removed file was? Also, did the add-in show up in the "Manage Add-ins" view of the Settings screen (within Excel), and if so, does it still show up or did you end up removing it? – CBHacking Oct 22 '15 at 20:45
  • I am seeing a similar scenario in Excel 2013 office15 where the HP ALM related TDExcelAddin.xla has been conflicting with personal.xlsb for some users, causing these ghost windows. It is not clear why. Disabling either of these two fixes it. – Amit Naidu Mar 21 '18 at 16:38
3

I had the same problem because I had created macros, which saves in PERSONAL.xlsb located in C:\Users\ username \AppData\Roaming\Microsoft\Excel\XLSTART You can just open from this location go to the View tab and select Hide. From now on when you open a file this will no longer open as well, but will still allow use of, for example, macros created that you'd want to use in multiple files. Now that I have seen the solution to the problem I recall having unhidden this PERSONAL workbook that gets created, just cannot recall as to why I would have done it.

  • Looks likely, I'll text this later. – Deanna May 29 '15 at 15:17
  • finally a location that actually existed on my computer! :D Except my file's name was not "PERSONAL" and I didn't knowingly create any Macros - I just deleted all the files in there and everything worked again. – Cold_Class Dec 18 '17 at 8:28
0

In my case I simply couldn't delete macros workbook as it was full of macros. What helped me was to make personal.xlsb file visible, modify it slightly (I changed the columns width), re-save it and hide again. And voila - the additional blank window doesn't appear anymore! It looks MS has made some changes into xlsb file format and the file needs updating.

0

Unhiding and re-hiding the personal.xlsb would get rid of the window for one session for me, but it wouldn't go away for good. So I added a marco that would automatically run every time I opened Excel to re-hide personal.xlsb. Here is the code:

Private Sub Auto_Open()

   Windows("PERSONAL.XLSB").Visible = True
   Windows("PERSONAL.XLSB").Visible = False

End Sub

If you add this to a module in Personal.xlsb it will run any time Excel is opened and will remove the second window.

Not the answer you're looking for? Browse other questions tagged or ask your own question.