I recently got a new PC(laptop) and installed cygwin on it, latest version as of today. For some reason cygwin behaves strangely. When i open the cygwin console or when i type commands in regular cmd.exe shell it takes like couple of minutes for the command to respond. I have cygwin on 2-3 pcs already at work and non behaved like that. once the cygwin terminal is open (mintty) command runs ok on it, but in the cmd it keeps hanging for 3-4 minutes! any idea why ? i thought it might be the antivirus, disabled it and still same behavior.

anyone got any idea ? (tried removing, reinstalling, removing registry keys and then resintalling, nothing helped for the first few times it worked ok, then all of the sudden it hangs again)


Try upgrading the cygwin package (only) to the current test release, 1.7.35-0.2. A problem with slow startup has been reported on the Cygwin mailing list, and the test release has improvements to address it.

  • looks like that did the trick, at least for now, i hope the next restart it will still be ok. – codeScriber Feb 17 '15 at 8:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.