55

I'm using Google Chrome. When I'm using Jenkins (This is remote service, I don't have control over it) then part of UI is displaying in my local language. How can I tell Jenkins to always display messages in English?

41

Another way to achieve this:

Install the Locale plugin. You can set the default language for all users, no matter the language configured in their browser.

https://wiki.jenkins-ci.org/display/JENKINS/Locale+Plugin

| improve this answer | |
  • 11
    Weird, it would be nice to have this option in settings. – sobi3ch Apr 18 '15 at 10:40
  • 1
    I agree, but this is how you set the default language for all users. – cbaldan Apr 22 '15 at 22:34
29

It can be done in Chrome by setting default language in settings, and it's probably working on other browsers but I didn't test it. enter image description here

| improve this answer | |
  • 4
    To clarify (wasn't obvious to me): drag the desired language to the top of the list. – Allon Guralnek Jul 8 '15 at 9:06
  • 23
    I don't want to change my Chrome language but Jenkins is so badly translated in my language. – Dalvik VM Feb 15 '16 at 13:36
19
  1. Click Manage Jenkins > Manage Plugins > ['Available' tab]
  2. In the Filter, search for: Locale .
  3. Click on Locale Plugin checkbox and Install without restart button.
  4. After installation is complete:

    • Under Manage Jenkins > Configure System there should be a "Locale" section.
    • Enter the default language_LOCALE code for English: en_US
    • Click on Ignore browser preference and force this language to all users checkbox.
| improve this answer | |
3

You can use a Chrome plugin to change Request Headers on domain base (I'm using "Header Hacker" but I think there are many other plugins of that kind) and replace the "Accept-Language" header for your jenkins domain to "en-US,en;q=0.5".

| improve this answer | |
  • Great solution, I didn't know about this possibility. Easy to use also on other domains. – CraZ Jan 28 at 7:55
2

Seems like chrome has an issue on this,
It kept sending Hebrew as the first option in the
Accept-Language on the header
although English was set to be the top-language on the list (Chrome settings > Languages)

Solution
And only after I've added some other language (Russian for instance) and set it to be the 'top' and then set the English back to be the 'top' it solved!

| improve this answer | |
0

If doing this in CloudBees Jenkins Enterprise/Core, you'll need to get the plugin from https://updates.jenkins.io/download/plugins/locale/ and upload it in ${OpCenterURL}/pluginManager/advanced .

When installed, in Manage Jenkins > Configure System in "Locale" section put en_US and check Ignore browser preference and force this language to all users as it seems not working without it.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.