0

I have been experiencing lots of BSODs in the past few weeks. The stop code is always 0x9F (driver_power_state_failure). I have saved four memory dumps from the past three days, and used WinDbg from the Windows SDK to compare them. The debugging details mostly look the same (see the bottom of this post).

Looking at the bucket IDs, it shows that nvlddmkm.sys has something to do with it. This is a driver from NVidia, and when I thought about it, the BSODs started appearing after updating my driver from version 325 to 347.

Always before such a BSOD comes up, I can see in Task Manager that the System thread (NT Kernel & System) uses up 25% of my 4-threaded CPU. After a few minutes, my PC becomes unresponsive in the most literal sense: the screen freezes. However: when I was Skype calling before a BSOD, I could still hear the other person while the screen was frozen. Another 8-10 minutes after freezing, the BSOD comes up.

I have already re-installed Windows from the manufacturer's restore partition. I also updated the NVidia drivers to the latest version (a few times, using clean installs).

I can provide the most recent dumps, minidumps or other info if needed.

PC specs:

  • Acer Aspire V3-771
  • Windows 7 Home Premium x64
  • 8GB DDR3 RAM
  • Intel Core i5-3210M 2.5GHz, Dual Core, 4-threaded
  • Full HD LCD screen (1920x1080, 32bit, 60Hz)
  • NVidia GeForce GT 650M

The following info has been Copy/Pasted from WinDbg. All 4 memory dumps looked the same, except for the stack trace.

0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_POWER_STATE_FAILURE (9f)
A driver has failed to complete a power IRP within a specific time.
Arguments:
Arg1: 0000000000000003, A device object has been blocking an Irp for too long a time
Arg2: fffffa8007ed0a10, Physical Device Object of the stack
Arg3: fffff80000b9c3d8, nt!TRIAGE_9F_POWER on Win7 and higher, otherwise the Functional Device Object of the stack
Arg4: fffffa800d8e1e10, The blocked IRP

Debugging Details:
------------------


DRVPOWERSTATE_SUBCODE:  3

IMAGE_NAME:  pci.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4ce7928f

MODULE_NAME: pci

FAULTING_MODULE: fffff88000f5a000 pci

DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT

BUGCHECK_STR:  0x9F

PROCESS_NAME:  System

CURRENT_IRQL:  2

ANALYSIS_VERSION: 6.3.9600.17298 (debuggers(dbg).141024-1500) amd64fre

DPC_STACK_BASE:  FFFFF8000480EFB0

fffff800`00b9c388 fffff800`02f41b92 : 00000000`0000009f 00000000`00000003 fffffa80`07ed0a10 fffff800`00b9c3d8 : nt!KeBugCheckEx
fffff800`00b9c390 fffff800`02edccfc : fffff800`00b9c4c0 fffff800`00b9c4c0 00000000`00000000 00000000`00000001 : nt! ?? ::FNODOBFM::`string'+0x33af0
fffff800`00b9c430 fffff800`02edcb96 : fffff800`03083140 00000000`00324674 00000000`00000000 00000000`00000000 : nt!KiProcessTimerDpcTable+0x6c
fffff800`00b9c4a0 fffff800`02edca7e : 00000077`aca84f27 fffff800`00b9cb18 00000000`00324674 fffff800`03051108 : nt!KiProcessExpiredTimerList+0xc6
fffff800`00b9caf0 fffff800`02edc867 : 0000001d`25ead5c1 0000001d`00324674 0000001d`25ead5e0 00000000`00000074 : nt!KiTimerExpiration+0x1be
fffff800`00b9cb90 fffff800`02ec8bca : fffff800`0304de80 fffff800`0305bcc0 00000000`00000002 fffff880`00000000 : nt!KiRetireDpcList+0x277
(...the top always looks like this, the rest of the stack mostly has some nvlddmkm in it)

STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

IMAGE_VERSION:  6.1.7601.17514

FAILURE_BUCKET_ID:  X64_0x9F_3_nvlddmkm_IMAGE_pci.sys

BUCKET_ID:  X64_0x9F_3_nvlddmkm_IMAGE_pci.sys

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:x64_0x9f_3_nvlddmkm_image_pci.sys

FAILURE_ID_HASH:  {86b85873-d822-8588-0151-5cf4191a225f}

Followup: MachineOwner
---------

0: kd> !devobj fffffa8007ed0a10
Device object (fffffa8007ed0a10) is for:
 NTPNP_PCI0017 \Driver\pci DriverObject fffffa80072b5e70
Current Irp 00000000 RefCount 0 Type 00000023 Flags 00001040
Dacl fffff9a1002db971 DevExt fffffa8007ed0b60 DevObjExt fffffa8007ed0f88 DevNode fffffa8007ecb8c0 
ExtensionFlags (0000000000)  
Characteristics (0x00000100)  FILE_DEVICE_SECURE_OPEN
AttachedDevice (Upper) fffffa8007ecbe40 \Driver\ACPI
Device queue is not busy.

0: kd> !irp fffffa800d8e1e10
Irp is active with 4 stacks 3 is current (= 0xfffffa800d8e1f70)
 No Mdl: No System Buffer: Thread 00000000:  Irp stack trace.  Pending has been returned
     cmd  flg cl Device   File     Completion-Context
 [  0, 0]   0  2 00000000 00000000 00000000-00000000    

            Args: 00000000 00000000 00000000 ffffffffc000000e
 [ 16, 0]   0  2 fffffa8007ed0a10 00000000 fffff88005bdc328-fffffa800d096650    
           \Driver\pci  nvlddmkm
            Args: 00000000 00000000 00000000 00000000
>[ 16, 2]   0 e1 fffffa800ae7b040 00000000 00000000-00000000    pending
           \Driver\nvlddmkm
            Args: 00000000 00000001 00000001 00000000
 [  0, 0]   0  0 00000000 00000000 00000000-fffffa800e30a4a0    

            Args: 00000000 00000000 00000000 00000000

0: kd> !devobj fffffa800ae7b040
Device object (fffffa800ae7b040) is for:
  \Driver\nvlddmkm DriverObject fffffa800ad60060
Current Irp 00000000 RefCount 0 Type 00000023 Flags 00002004
DevExt fffffa800ae7b190 DevObjExt fffffa800ae7bb48 
ExtensionFlags (0x00000800)  DOE_DEFAULT_SD_PRESENT
Characteristics (0x00000100)  FILE_DEVICE_SECURE_OPEN
AttachedTo (Lower) fffffa8007ecbe40 \Driver\ACPI
Device queue is not busy.
  • Did the update was done to newest drivers from Nvidia or from Acer? I had long time ago issues when installing vanilla NVidia drivers on my laptop, all was solved when installed drivers from Dell, which even updated was way older than newest Nvidia... I know Acer is not Dell, but this may apply... Laptop manufacturers sometimes do stupid things and alter hardware just a bit (I mean: order it to their specs and reqs) – AcePL Feb 19 '15 at 12:34
  • You might want to see if you can figure which device is being blocked if you have a Nvidia chipset those drivers should be installed. You should also make sure all other device drivers are installed. The fact you have reinstalled Windows and this problem has not resolved itself indicates a hardware issue though. – Ramhound Feb 19 '15 at 12:39
  • @AcePL I updated the NVidia driver manually, not via Acer or anything, so that's not the problem here. – thecatlover1996 Feb 19 '15 at 13:48
  • @Ramhound I checked the forum you linked, executed the exact same commands as peebee did there. I appended the output of the commands to the Bugcheck Analysis. – thecatlover1996 Feb 19 '15 at 13:58
  • I was asking for the source, not method. If you installed driver downloaded from Nvidia, it may not work, while driver downloaded from Acer might. But again: all depends. If Acer links to Nvidia, then fine. If they have package on their own server, it may as well be modified driver for this device specifically. If you did it via option in Device Manager, then... hmpf... It could go either way, I'm afraid. Check for Acer Driver. – AcePL Feb 19 '15 at 13:59
0

The error is generated by nVidia display driver. Instead of recovering from a crash, it crashes the whole system bus driver. Since system drivers cannot be user-altered, theres is nothing you can do directly to the driver.
You should use a stable, older driver like 332.21 or 325.x. Try to get the driver from your manufacturer's website, to make sure that it is compatible with your device. If you can, try to note the version number (in your case 311.00) and download it directly from the nVidia website not Acer's. OEMs tend to alter/customize drivers.

  • Thanks for the tip, I will install 332.21 and see if I get any more blue screens in the next few days. If I don't, I'll set this one "solved" :) – thecatlover1996 Feb 19 '15 at 10:43
  • If you are in luck, the new driver did not break anything in windows and things will work fine with the older version. – Overmind Feb 19 '15 at 11:02
  • This honestly is horrible advice. The 347 driver branch is stable its been out for more then 3 months only receiving updates for new game releases. Based on a duplicate question, their solution to this problem, was to reinstall the drivers. Others have had to resort to replacing the hardware. If fresh Windows installations have this problem that is a good sign its a hardware issue not a software problem. – Ramhound Feb 19 '15 at 12:34
  • Hardware problems are much more unlikely than software problems. As for the 347 series, I do not validate them as stable yet and I do extensive testing with drivers on multiple cards and OSes. There are way too many compatibility issues with other than DX11 games, specially physx related. Do not forget that nVidia drivers are the number one error generator in the post-Vista era. – Overmind Feb 19 '15 at 13:29
  • @Overmind - Who says they are the number one error generator? Because I have seen lots of problems with Intel and AMD display drivers also. I still believe using an older display driver to be bad advice. – Ramhound Feb 19 '15 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.