16

I have a multi-boot computer, one of the partitions is taken by Windows 10 technical preview and another one is also ntfs.

Booting in an Ubuntu-eOS system I get this errors when trying to mount these partitions. How to fix this? Should I uninstall Windows 10? Should I try to fix it from inside Windows, from Ubuntu?

enter image description here

enter image description here

  • 1
    Do you need write access? If not, the error message advises that you can mount the partitions as read-only. If you modify any files, save the modified contents in a partition that Windows and Linux can both access; or save in the Linux partition and use ext2sd to access it. You can then copy back the modifications when you reboot Windows. – AFH Feb 21 '15 at 20:47
20

This happens since Windows 8, when you use the new hybrid shutdown, which is basically a logoff + hibernation. And the hibernation can cause issues, if you now mount the NTFS partition.

You have to do a full shutdown in Windows 10, by pressing the SHIFT key + clicking on shutdown.

  • 2
    hopefully windows cannot see my ext4 partitions :) – user162573 Feb 21 '15 at 20:15
  • 1
    You can stay calm, it doesn't :) – Fabo.sk Feb 21 '15 at 20:26
  • 1
    I guess this is the answer. But considering the new magic of the Windows wizards, I have no patience for such aggravation :) Those partitions were empty anyway, that Win10 install a few hours old. Deleted them with gparted. – user162573 Feb 21 '15 at 22:13
12

It has to do with Windows 10 Hybrid Shutdown (a.k.a. Fast Boot) feature. See http://www.howtogeek.com/236807/how-to-mount-your-windows-10-or-8-system-drive-on-linux/.

Short term solution: be sure to select the “Restart” option in Windows instead of the “Shut down” option whenever you want to switch to Linux.

Long term: Permanently Disable Hybrid Boot From Windows, the Power Options Control Panel, and click “Change what the power buttons do”. You may have to click the “Change settings that are currently unavailable” link to enable changing this configuration. Scroll down and uncheck the “Turn on fast start-up (recommended)” option. Click “Save changes” to save your changes.

The next time you shut down Windows, it will perform a full shut down, just like Windows 7 always did.

  • 3
    It had been a long time since the last time I used Windows that only recently I came across this problem. Indeed this solution proved much more useful than having to remember to hold the Shift key pressed whenever you turn off Windows. – Simón Oct 12 '16 at 4:25
  • This was so counter-intuitive. I was doing full shutdown thinking that was more thorough than just restarting Windows. – MasterHD Sep 25 '17 at 11:54
3

Use ntfsfix in the terminal , even if you can't access Windows

sudo ntfsfix /dev/XY //Previous wasn't working for me.

where XY is the partition

e.g sda2 or sdb1

ntfsfix repairs some fundamental NTFS inconsistencies, resets the NTFS journal file and schedules an NTFS consistency check for the first boot into Windows.

1

A bit late to this thread, but I thought it worth making these observations:-

  • When Ubuntu Linux (I'm on 16.04LTS) starts, it does not seem to automatically mount non-root partitions. If I try to start Thunderbird, where my TB profile is on a data partition, I'll get an error. The solution is to go into Nautilus, or similar, and click on the data partition, which will mount, provided there are no errors like described in this thread.

  • I'm on dual-boot too. It used to work switching off the Windows Fast-Start (that is, making sure the Windows was properly Shut Down before booting into Linux). That has stopped working recently and I always get an error as described by the original poster.

  • Using Chkdsk /f in Windows does not fix the problem. Ubuntu Linux still gives the same error.

  • I therefore have to start a terminal and run sudo ntfsfix /dev/XY (where XY is the partition e.g sda2 or sdb1) every time I boot to Linux. This fixes the partition and usually throws errors to do with MFT mirrors. No idea why as I've run every diskcheck I can on the partition and it's all fine.

So I would say that NTFSFIX is the answer, but I cannot find why it might be that this problem persists on dual-boot machines, even though Windows is closed down properly. Experience tells me that it will be Windows causing the problem, not Linux, so the only option I'm left with if I want to avoid the NTFSFIX work-around, would be a re-install of Windows 10.

  • The fix is to disable "Fast Startup" and Hibernation, as Windows otherwise does not shut down properly. – Aaron Franke Jun 16 '18 at 3:57
  • The disabling of "Fast Startup" didn't work in this case. If you see the second comment in the post above yours. It used to work to do that, but a Windows update seemed to change things. I have since re-installed the Windows 10, but the problem persists. So it could be the NTFS partition is shot somehow. – Kalico Jun 20 '18 at 10:17
-2

Convert your Data partitions to Fat32. Keep 1 partition formatted NTFS for files larger than 4GB. Fat32 is not affected by Hibernation.

  • 1
    Converting to FAT32 isn’t necessary, but even it was, you don’t indicate how to do that. – Ramhound Dec 9 '18 at 3:44
  • The info that fat32 partitions are not affected is interesting. Even so, it doesn't seem safe to change partitions that are involved in a state of hibernation. Also: (1) this was fixed as in the definitive answer, (2) I was never interested in changing the partition structure, and (3) using fat32 is a far too severe solution anyway, not only in a scenario with pre-existing partitions, but even as a plan for creating a new structure. Simply shutting down Windows fully is a very cheap and simple way to go. – user162573 Dec 9 '18 at 12:48
  • @Ramhound - This was fixed a long time ago, I still use full Win10 shutdown as a solution. But is it even correct that the odd scenario of fat32 partitions for Win10 is possible and is not affected by the problem? And how safe is that? – user162573 Dec 9 '18 at 12:50
  • Are you sure?? It seems that win10 is automatically formatting its drive to ntfs upon installation, as stated here and even that no Windows above XP is supporting installation on fat 32. – user162573 Dec 9 '18 at 13:14

protected by Ramhound Dec 9 '18 at 3:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?