I have a (Dual booted) Dell Inspiron N5110 with IDT High Definition Audio CODEC and Windows 7.

In Windows 7, I can hear sound from the speakers, but when I plug headphones in, I can't hear anything through either playback device.

In Ubuntu, I can hear sound from the speakers, and when I plug headphones in I can hear the sound through the headphones. This is what I want to happen in Windows 7.

I have tried using the test function on both the "Headphones / Speakers" and the "Communication Headphones" when I have headphones plugged in (neither work). When I click the sound icon in my system tray when I have headphones plugged in, I can see the green line moving up and down when sound is playing, but I can't hear a thing.

This is what my sound window looks like in windows 7:

Sound dialog Windows 7

  • What happens if you click the bottom device, then press Set Default? In theory that should fix the issue. Also, reboot the system after that or reopen the program that uses the audio device so it will be set to the correct one. (may not always work, which is why I suggest to reboot) – LPChip Feb 22 '15 at 14:41
  • @LPChip When I Right Click -> Set as default, nothing happens. I can right click -> set as default communications device and that changes it - no sound though. I have also tried right click -> test on both of them and I can't hear anything. – starbeamrainbowlabs Feb 22 '15 at 14:44
  • 1
    You must set the Communications Headphones as default, notice the check mark, then reboot the system, so every audio device goes through that. – LPChip Feb 22 '15 at 15:30
  • @LPChip I can't set them as the default. I have set them as the default communications device, restarted, and still no luck. It was working before without the communications headphones set as the default device. Imgur link of what it now looks like: i.imgur.com/pMJNWdk.png – starbeamrainbowlabs Feb 22 '15 at 15:51
  • if you cannot set them as the default (not communication device) then thats where things aren't working. Try plugging the device in a different USB port, preferably not through a hub, and see if you can set it as default now. – LPChip Feb 22 '15 at 15:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.