0

I have had problems recently after I formatted a USB flash drive on my Chromebook. When I plugged it in to my computer, it did not show a notification for the drive, or indicate that it recognized it in the "This PC (Computer)" menu.

To resolve this problem, I went to Computer Management > Disk Management > Right-clicked on the drive (it recognized it, but it just wasn't showing up) > New Simple Partition... > Followed the steps and formatted it to NTFS. I named it "Backups".

When I plugged it into my Chromebook, it recognized it, but it gave me a toast notification saying "Sorry, at least one partition on your device could not be mounted". When I opened it in the file manager, its name was "UNTITLED". When I put an empty folder on it, it did not show up in Windows.

I formatted the drive again in my Chromebook, and this time went to Windows and formatted it to a FAT32 filesystem, but I'm still having the same problems. The only help I found was here, where I was told to reformat the drive on my Chromebook.

This was working before I formatted it on my Chromebook, what has happened?

6
  • You don't mention the size of the drive. One possible issue is that for smaller drives(e.g. 2 GB), plain FAT might be best, for very large, exFAT might be needed etc. Also, you might need to set the allocation unit size. See makeuseof.com/answers/format-16gb-usb-drive-ntfs-fat32 for more on this. – DrMoishe Pippik Feb 22 '15 at 16:53
  • @DrMoishePippik The size of my drive is 29.8 GB, not that large compared to some other drives. I chose the allocation unit size that was pre-selected on Windows, 16 kilobytes. – James Ko Feb 22 '15 at 16:58
  • @DrMoishePippik Edit: just tried exFAT, got the same error. – James Ko Feb 22 '15 at 17:06
  • I'd suggest a complete reformat without partitioning, FAT32, default allocation unit size, performed on the Windows box, as that should restore it to original condition. If that was usable by Chrome before, it should still be. – DrMoishe Pippik Feb 22 '15 at 17:07
  • @DrMoishePippik I just finished formatting the drive after right-clicking > Format, setting everything to default and unchecking the "Quick Format" box. Still gives me the same error... – James Ko Feb 22 '15 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.