1

I am a total linux beginner and running Linux Mint 17 Qiana on a Dell Latitude D520. Because I can't connect to any wireless notwork, I tried to configure some hardware stuff I barely understand:

First, I tried to install firmware. This is the output after lspci -nn -d 14e4:

02:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0     100Base-TX [14e4:170c] (rev 02)
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11a/b/g [14e4:4312] (rev 01)

After installing several driver and firmware packages, I don't even remember all of them, I came to the conclusion that I am missing a wireless interface. After running iwconfig I receive the following:

lo        no wireless extensions.

eth0      no wireless extensions.

usb0      no wireless extensions.

wlan0 is missing, as i observed. Further, lspci -k revealed that a driver is running, but no kernel module (which might be unusual, I don't know):

Network controller: Broadcom Corporation BCM4311 802.11a/b/g (rev 01)
Subsystem: Dell Wireless 1490 Dual Band WLAN Mini-Card
Kernel driver in use: b43-pci-bridge

And iw dev does not return any output at all.

Finally, I used dmesg | grep firmware to find out that I'm having serious trouble with my firmware:

[   20.651112] b43 ssb0:0: firmware, attempted to load /lib/firmware/b43/ucode5.fw, but failed with error -22
[   20.651119] b43 ssb0:0: Direct firmware load failed with error -22
[   21.140191] b43 ssb0:0: firmware, attempted to load /lib/firmware/b43/ucode5.fw, but failed with error -22
[   21.140197] b43 ssb0:0: Direct firmware load failed with error -22
[   21.254324] b43 ssb0:0: Direct firmware load failed with error -2
[   21.255437] b43 ssb0:0: Direct firmware load failed with error -2
[   21.258081] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.

The website lead me to http://linuxwireless.sipsolutions.net/en/users/Drivers/b43/#Other_distributions_not_mentioned_above, where I came to the conclusion that I don't understand anything.

Am I right considering that the problem lies in the faulty configuration of my driver/firmware, and if so, how can I fix it? How can I figure out which of the solutions on http://linuxwireless.sipsolutions.net/en/users/Drivers/b43/#Other_distributions_not_mentioned_above to follow? And how can I make sure that none of my earlier attempts to install drivers does not interfere with these solutions?

I'm sorry for my lack of knowledge and grateful for any piece of advice. Thank you for your time.

1

It seems like you're still lacking firmware for your wi-fi chipset. As evidenced in Ubuntu docs*, for BCM4311 you will need to install firmware-b43-installer package:

apt-get install firmware-b43-installer

Do it while being connected to the Internet by cable, it should download all firmware needed to use your chipset. After that - reload b43 module (as root: modprobe -r b43 && modprobe b43) or just reboot. Your wi-fi card should be working now.

*-Linux Mint is a direct descendant of Ubuntu, even using its repositories.

3
  • thank you for your time. apt-get install firmware-b43-installer returned the following: Reading package lists... Done Building dependency tree Reading state information... Done firmware-b43-installer is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 456 not upgraded. If i'm not mistaking, this means i had already installed this package and my problem persists.
    – Gerry
    Feb 23 '15 at 15:17
  • Did you try reinstalling it? apt-get install firmware-b43-installer --reinstall? I'm positive this should download firmware needed for your Broadcom chipset (and for many others, by the way). You can also try installing proprietary Broadcom driver: apt-get install bcmwl-kernel-source. Reference: help.ubuntu.com/community/WifiDocs/Driver/bcm43xx .
    – bardzusny
    Feb 23 '15 at 16:53
  • apt-get install firmware-b43-installer --reinstall worked perfectly! You just solved the problem I've been dealing with since I installed linux for the first time. Thank you very much!
    – Gerry
    Feb 23 '15 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.