1

I'm having trouble getting all my searches not to use yahoo.com as my search engine in Firefox.

After changing settings in Preferences>Search to Google, Firefox still uses Yahoo when I open a new tab and use the main (largest) search box, which is outlined with the large red rectangle below. The smaller search box (marked with a smaller red rectangle) does however use Google. enter image description here.

I'm stuck searching for answers since I'm not sure what to call the large search box versus the smaller search box, and I'm not sure if it is normal that these two are acting differently.

0

You can change the selected search engine by doing the following:

  1. Type about:config in the address bar.
  2. Click on the "I'll be careful, I promise" button.
  3. Change the following entries:
  • Did this, and it didn't work. I then searched "yahoo" once I typed "about:config" and changed a few results to "Google". Now the big red rectangle search box does not work at all... Guess I should have followed through with my "promise" a bit more closely – GIStack Feb 22 '15 at 21:40
  • You broke it by changing the url entries. Did you change the keyword.URL entry? See my updated answer. – Yass Feb 22 '15 at 21:41
  • I did a clean reset of all about:config, then changed search engine in preferences - now everything works as expected! Didn't even need to go into about:config. I think I had some atypical thing going before. – GIStack Feb 22 '15 at 21:46
  • Just noticed that this clean reset also got rid of my extensions. I suspect that one of these extensions was responsible for the unwanted search behavior. – GIStack Feb 22 '15 at 21:51
  • Good to hear. I had to modify the two entries in my answer to change the "New Tab" search engine. I guess resetting your about:config is another way to do it if you don't mind losing any other changes you may have made. – Yass Feb 22 '15 at 21:51
0

There are two ways to select a search engine in newer versions of Firefox: from the icon list that shows as soon as you start to search, which is a single-use change, or by selecting Change Search Settings, and select Default Search Engine from the list -- this setting stays in place.

You can also get to that dialog from Tools -> Options -> Search.

  • I do not have an options dialog under tools? The other way you mentioned did not work to change the behavior of the search box marked by the big red rectangle in my original question. – GIStack Feb 22 '15 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.