0

I have two bootloaders now; I have the GRUB and the EasyBCD that I've created before the Linux was installed properly. After reinstalling Ubuntu for the second time, the GRUB came right, but now that I have the main GRUB loader, I'd like to delete the second one. The thing is, when I select "Ubuntu", it will load straight to Ubuntu, but if I click Windows, then it shows the second one, which is annoying.

Here’s the GRUB menu I'd like to use.

enter image description here

I’d like to get rid of this menu which opens after selecting Windows Boot Manager from the GRUB menu.

I don’t want to make any errors (by this I mean that I don’t want to delete the first bootloader, which gives me access to Ubuntu and Windows) so I’m posting this question because I don't really know if I just uninstall EasyBCD it won’t delete the second GRUB (I guess?).

Another thing I don’t understand, it says I have 3 entries and then I also have a default?

1

I have little familiarity with Linux or grub, but since you have had no answers in months, I'll try to answer based on what I know about the Windows boot environment. If nothing else, maybe this answer will prod someone who knows better into answering.

First, EasyBCD is not the Windows bootloader, and it does not install a Windows bootloader. It is merely a GUI tool that you can use once Windows is booted - a replacement for the command-line tool bcdedit and for the "boot" tab in msconfig. EasyBCD lets you modify Windows' boot configuration database (BCD) more easily than with Windows' built-in tools. (n.b.: The BCD is actually a registry hive, just like the "system" or "software" hive, but it is not normally loaded while Windows is running.)

But even after EasyBCD is installed, it does not establish any new "Windows bootloader". Your second screen is not being displayed by EasyBCD. It is displayed by bootmgr, which came with Windows. Early in the Windows startup sequence, bootmgr displays the Windows boot menu as you see in your second screen. The menu is defined in the BCD. (That's for Vista and later. For XP and earlier the program that displays the menu is ntldr, and the menu is defined by a text file boot.ini.) When you select a Windows version from the BCD menu, bootmgr loads and runs winload.exe, which loads the rest of Windows from the drive.

Normally your machine's firmware (EFI, looks like) would load bootmgr. With grub installed, EFI loads grub instead. grub gives you a menu that includes "Windows boot manager". When you select that, grub loads bootmgr and then gets out of the way. The rest of the Windows boot happens just as it would if grub hadn't been there.

You can't get rid of bootmgr because grub doesn't know how to do what bootmgr does (which is normally to load winload). You can uninstall EasyBCD, but that won't change your menu setup. The BCD will still be in its current state. Same for whatever grub uses to define its menu.

It's a minor mystery, though, as to why your BCD has three entries in it (as displayed by EasyBCD)... but bootmgr is displaying only one option (for Windows 8.1). It might be that it doesn't like those "ubuntu" entries for some reason.

After that, it's a mystery as to why it's displaying the menu at all when it's only displaying one option. Normally when there's only one option in the BCD no menu is displayed; it just skips through it.

It's also a mystery to me as to why you would have "ubuntu" options in the BCD at all. I don't think bootmgr has any idea how to boot ubuntu. I think the path to booting ubuntu can't involve grub at all... unless grub, like bootmgr, uses the Windows Boot Configuration Database, which seems to me to be wildly unlikely. But as I said, I don't know much about linux or grub.

A quick cosmetic fix would be to use EasyBCD to set the timeout to 2 seconds or so. You'll still see the second menu but only for two seconds.

If you don't mind experimenting and a little bit of risk, you could try this:

  1. Boot Windows.
  2. Use EasyBCD to save your current BCD (the backup/repair button).
  3. Explore the stuff under the backup/repair button and be sure you understand how to restore the BCD from the backup you just made.
  4. Use EasyBCD to remove the two "ubuntu" options from your BCD.
  5. Reboot and see what happens.

I think the result would be what you want. If it isn't, I can't imagine that this would interfere with your ability to boot Windows. So if the result is bad (you no longer can boot ubuntu) then you can boot Windows, use EasyBCD to restore the BCD from your backup, reboot and there you are.

  • 1
    Yes, this approach would work well with little convolution needed on behalf of the user to correct anything on the Linux/GRUB side of things. You can also choose to use EasyBCD's "skip boot menu" option instead of setting the timeout to zero, it will accomplish the same thing. +1! (for the record and as you suspected, GRUB does not share any entries with bcdedit) – Mahmoud Al-Qudsi Feb 29 '16 at 18:26
0

I know this is an old post, but I've passed a couple of hours trying to fix this second bootloader screen on my machine and, finally, figured out the solution for me and I'm going to describe it to maybe save someone's time. First of all, the guy above is totally correct about the windows bootmgr stuff and windows have a tool to configure it manually and you don't even need the EasyBCD at all. The tool is bcdedit, that you can acess through the command prompt. I found out two ways to solve the problem:

  1. When you have only one OS entry on the bootmgr options, it is booted automatically after selecting windows on grub. So you can delete all the other entries parallel to the windows and the boot manager entry. To do that follow these steps:

    • Open cmd as admin and type "bcdedit /store c:\Boot\BCD" and press Enter. This shall shows all the existing entries on the bootmgr.
    • Indentify the entries that you want to delete looking at the description lines and identificator of each one. You MUST keep the "Windows Boot Manager" and your windows version entries, otherwhise you're gonna have problms on boot.
    • To delete a entry just execute 'bcdedit /store c:\Boot\BCD /delete ID' where ID is the entry identification code. Ex: "bcdedit /store c:\Boot\BCD /delete {5e384e54-f790-11e8-8d8-83334a362d08}". The "-" and "{}" are necessary.
  2. You can just set the windows entry as default system and set the timeout to 0, so the bootmgr is going to boot windows automatically after selecting windows on grub.

    • open cmd as admin and run the command: "bcdedit /store c:\Boot\BCD" and copy the ID of you windows
    • run "bcdedit /store c:\Boot\BCD /default ID"
    • run "bcdedit /store c:\Boot\BCD /timeout 0"

This should be enough. I recommend the second way, which you won't risk deleting the windows neither the bootmgr entries.

P.S.: I'm not an english native speaker, so probably I've commited some errors, please don't mind them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.