4

I stupidly denied access to my user folder for the administrator group, and now I can't fix the problem.

I set the Administrators and HomeUsers groups' permissions on my Account's user folder to Deny for Full Control (Which in turn set everything to deny). There was a dialog box telling me Deny takes precedence, but I didn't realize the implications at the time.

A regular administrator account doesn't work to fix the problem because they're automatically in the administrator group. I know I didn't block the SYSTEM user, but I haven't found any information on the internet to let me use that.

For posterity: I was trying to prevent my XP computer from getting access to those folders, but that's a different question entirely.

11
  • What did you do exactly. Knowing this information can help determine what you need to do to reverse it. – Ramhound Feb 23 '15 at 14:31
  • I assume a System Restore didn't help? – Dave Feb 23 '15 at 14:35
  • 1
    I set the Administrators and HomeUsers groups' permissions on my user folder to Deny for Full Control (Which in turn set everything to deny). There was a dialog box telling me Deny takes precedence, but I didn't realize the implications at the time. I don't even know if I have System Restore working, but I'm pretty sure I turned it off (tiny hard drive). – Mengmoshu Feb 23 '15 at 14:53
  • 1
    Try going to Security tab > Advanced (at bottom) > Change Permissions > Administrators > tick Replace all child object permissions with inheritable permissions from this object (at bottom) > Edit > Full Control – ᔕᖺᘎᕊ Feb 23 '15 at 15:05
  • 1
    @ᔕᖺᘎᕊ Looks like your advice to use the Hidden Admin account worked. You should make an Answer out of it. – Mengmoshu Feb 23 '15 at 15:32
2

You can try using the Hidden Administrator Account (slightly higher privileges than the normal admin):

  • Open an elevated command prompt (Start menu > cmd > right click > run as admin)
  • Run this: net user administrator /active:yes
  • Logout
  • Login via the new account
  • Go to your blocked folder
  • Right click the folder > Properties
  • Go to the Security tab > Advanced (at bottom) > Change Permissions > Administrators > tick Replace all child object permissions with inheritable permissions from this object (at bottom) > Edit > tick Full Control

It might take a bit of manual labour to get this fully working - but it works!

Remember to disable the Hidden Admin account afterwards (for security)! - run this command: net user administrator /active:no

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.