0

Here is my environment:

WAN Cable -> Docsis 3 Zoom 1094 Modem -> TP-Link AC1750 Dual Link Router -> Server to forward

(dynamic public IP) -> Modem: (internal nic: 192.168.100.1) -> Router: 10.1.1.1 -> Internal Server (10.1.1.10)

I turned off the firewall to Internal Server for now to make sure everything can get in/out. It is also set to have a static IP

In the 'Router' 10.1.1.1. management interface I went to Forwarding -> Virtual Servers and added an allow to 10.1.1.10 on port 80 TCP/UDP and enabled it

I change the router management interface to 8080 so there is no port 80 conflict just because.

Docsis 3 Zoom 1094 modem has no configurable options, just an info page at 192.168.100.1, this is accessible from all PCs on the network.

When I attempt to access my public IP—as listed in the router and on whatsmyip.com—I get a error that no data was received. Internally, when accessing the IP the web server responds.

Strangely, when I enter my public IP on a PC in my internal network it still lands on the internal server page I am trying to access.

I can not figure out what configurations are wrong. UPNP is on, DMZ computer is off, no port triggering rules. More info below

Here is the cable modem info page: (from 192.168.100.1) enter image description here

Here is some IP and router info:

enter image description here

Here is the LAN info: enter image description here

WAN info from router: enter image description here

NAT Settings: enter image description here

Port forward settings: enter image description here

  • Added a lot of info. There's a DMZ setting which I tried setting the server to but that also didn't seem to work? ;( – Abraxas Feb 23 '15 at 20:41
  • 1
    cox.com/residential/support/internet/… Inbound port 80 is blocked by Cox. – heavyd Feb 23 '15 at 20:46
  • Welp, that was dumb. ;( Is there any way to get around this so that I can point to domainame.com (on port 80) and have that go to dynamicip.com:port## so that it is easy for the user to access but still avoids the port 80 block? Is this something cloudflare coud do? – Abraxas Feb 23 '15 at 21:18
  • I haven't used cloudflare, but if they can proxy your site on a different port, say 8080, instead of 80, then that should help you. – heavyd Feb 23 '15 at 21:24
0

Issue was due to Cox blocking port 80. Currently this is not resolved, I am looking in to proxying (perhaps through cloudflare) sitename.com on port 80 to public-ip:otherport so that this inconvenience isn't visible to people accessing the site.

  • Port 80 blocking is to prevent a residential connection from runnibg a webserver. You can upgrade to a business connection and that'll let you host on port 80. – Nelson Feb 23 '15 at 21:57
  • Since this will hardly have any load (maybe 5 max connections?) and minimal traffic I don't want to spend the money on a business account esp after dealing with 2 bad router/modems they sent me initially and a botched initial setup. I also don't need the static =/ – Abraxas Feb 24 '15 at 17:26
  • Then you can setup the connection on a custom port since it looks like the connections are people you know. – Nelson Feb 24 '15 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.