2

A Windows 8 tablet keeps scanning for Wi-Fi networks even though it's already connected to a preferred one.

I can see some other networks appearing and disappearing in the connectivity area on the right side of the screen. I'd like to turn that feature off so the device sticks to the networks already saved as preferred and doesn't search for new ones; having to enter the SSID manually whenever needed is fine with me.

I know I can turn the Airplane mode on but then I won't be able to use my home network.

Tried to search for wifi scan off but all it shows me is about Android. Tried changing the query to be wifi scan off windows but there's literally nothing relevant, not even questions.

How do I turn Wi-Fi discovery off? I don't need the device constantly scanning the new networks. Thanks

  • here – Ramhound Feb 24 '15 at 11:46
  • @screener suggested removing the desktop tag - not sure what are you trying to accomplish. I got an answer here suggesting a solution for a Windows Phone, while I'm on the desktop version of Windows, so the tag is required. – WhatHiFi Feb 24 '15 at 13:20
  • @Ramhound well, I see one. Apparently the Windows 8 tag didn't work for that person. I'm on desktop windows, since there's no windows-desktop tag, I'm using that one. – WhatHiFi Feb 24 '15 at 13:25
2

Well, it seems to me that you want to stop Windows to inform you when new networks are found. Then you can go to to

settings -> wifi -> advanced-> and uncheck "notify me when new networks are found".

And if you want to turn on or off network discovery here is how, it is realy nice explenation for windows 7, but I think it shuold be the same

  • This might work on a windows phone device, but I'm on a desktop version. Thanks for your input anyway – WhatHiFi Feb 24 '15 at 13:21
  • @Ramhound are you sure? q=notify+me+when+new+networks+are+found – WhatHiFi Feb 24 '15 at 13:26
  • @Ramhound yes, that's the same information as you provided in comments to the question - and thanks, but that's not what I was asking about. My issue had nothing to do with network discovery. I've posted the solution in my answer below. – WhatHiFi Feb 25 '15 at 15:48
0
  • go to the Control Panel
  • choose Networks and Sharing -> Change Adapter Settings (in the left column)
  • choose your Wi-Fi adapter -> right click -> Properties
  • click Configure (under "Connect Using")
  • go to the Advanced tab -> search for the following options
    • Background Scan - set to Disabled
    • Foreground Scan - set to Disabled

Applies to the Atheros adapters.

0

As well as the previous solution, which didn't help me - it's not an Atheros card - I found another solution for my Windows 10 laptop that has an Intel wifi adapter. It constantly scans for other wifi networks, and drops the existing connection if it finds a stronger one. This even happens at home, where my and my neighbours' routers are not "open", and I am definitely authenticated to my own. My own router is nearly always the highest signal strength, but if someone else's momentarily gets through the ether a nanosecond faster, blam, the connection is dropped.

In the Intel driver (mine's a Dual-Band Wireless AC-8260, but I'm sure most recent Intel chipsets have the same option available), there is a option called Roaming Aggressiveness. Set this to 1. Lowest, and it disables the search for stronger networks. https://www.intel.com/content/www/us/en/support/articles/000005546/network-and-i-o/wireless-networking.html

Frankly, unless you're striding through office buildings typing on your tablet and automatically logging onto a whole lot of Wifi endpoints as you do so, having the thing constantly seeking new networks seems like a waste of time.

To modify Roaming Aggressiveness in the driver config:

  • type ncpa.cpl into the Windows search box (or type it in the start menu).
  • this pops up the Network Connections control panel, and a laptop/desktop user will probably see Ethernet and Wi-Fi adapters in there.
  • right-click on the Wi-Fi adapter icon and select Properties
  • click the Configure button on the driver property page
  • on the Advanced tab, scroll down the Property list and set Roaming Aggressiveness to 1. Lowest
  • click OK to all the settings pages you've just opened

Note that I previously had this set to 2. Medium-Low, and didn't get much benefit out of it. Now, in a hotel with a lot of competing signals, it hasn't budged - no more drop-outs.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.